Toad World® Forums

Session Default Date format may not work (v 7.1)


#1

Reproduce:

  1. Set in Preferences Date Displayed Format to 2014.09.08 (RRRR.MM.DD)

  2. Set is Preferences Session Default date format to

  3. Restart sqlnav for clean result

  4. Connect to DB and select nls (not correctly set NLS_DATE_FORMAT):

select * from NLS_DATABASE_PARAMETERS

NLS_NCHAR_CHARACTERSET AL16UTF16
NLS_LANGUAGE AMERICAN
NLS_TERRITORY AMERICA
NLS_CURRENCY $
NLS_SAVED_NCHAR_CS CL8MSWIN1251
NLS_ISO_CURRENCY AMERICA
NLS_NUMERIC_CHARACTERS .,
NLS_CHARACTERSET CL8MSWIN1251
NLS_CALENDAR GREGORIAN
NLS_DATE_FORMAT DD-MON-RR
NLS_DATE_LANGUAGE AMERICAN
NLS_SORT BINARY
NLS_TIME_FORMAT HH.MI.SSXFF AM
NLS_TIMESTAMP_FORMAT DD-MON-RR HH.MI.SSXFF AM
NLS_TIME_TZ_FORMAT HH.MI.SSXFF AM TZH:TZM
NLS_TIMESTAMP_TZ_FORMAT DD-MON-RR HH.MI.SSXFF AM TZH:TZM
NLS_DUAL_CURRENCY $
NLS_COMP BINARY
NLS_LENGTH_SEMANTICS BYTE

select * from NLS_INSTANCE_PARAMETERS where value is not null

NLS_LANGUAGE AMERICAN
NLS_TERRITORY AMERICA
NLS_LENGTH_SEMANTICS BYTE
NLS_NCHAR_CONV_EXCP FALSE

select * from NLS_SESSION_PARAMETERS

NLS_LANGUAGE AMERICAN
NLS_TERRITORY CIS
NLS_CURRENCY р.
NLS_ISO_CURRENCY CIS
NLS_NUMERIC_CHARACTERS .,
NLS_CALENDAR GREGORIAN
NLS_DATE_FORMAT DD-Mon-RRRR
NLS_DATE_LANGUAGE AMERICAN
NLS_SORT BINARY
NLS_TIME_FORMAT HH24:MI:SSXFF
NLS_TIMESTAMP_FORMAT DD.MM.RR HH24:MI:SSXFF
NLS_TIME_TZ_FORMAT HH24:MI:SSXFF TZR
NLS_TIMESTAMP_TZ_FORMAT DD.MM.RR HH24:MI:SSXFF TZR
NLS_DUAL_CURRENCY р.
NLS_COMP BINARY
NLS_LENGTH_SEMANTICS BYTE
NLS_NCHAR_CONV_EXCP FALSE

5. I think setting “NLS_TIMESTAMP_FORMAT” also must be changed

**


#2

Hi smithsv,

Thanks for your report issues.

we have create Defect SQLNAV-1754 for NLS_DATE_FORMAT, we will try to fix it soon.

And for your suggestion that also change “NLS_TIMESTAMP_FORMAT” , we will implement it as feature.

Thanks,

Michael