Toad World® Forums

Cannot view tables in object explorer - The user does not have permission to perform this action - TOAD for SQL Server Freeware 6.1.0.1759

When I start TOAD and connect to a SQL Server database with my credentials, all objects appear in the Object Explorer underneath all tabs. However, upon a connection refresh or new connection, TOAD throws the message “The user does not have permission to perform this action”.

When I restart TOAD, the problem goes away then comes back with no discernable pattern.

I’ve found other posts concerning this error but none where the connected user was able to view the tables with no errors before. I’m using Cannot view tables in object explorer - The user does not have permission to perform this action.

I’m using TOAD for SQL Server Freeware 6.1.0.1759.

Suggestions, solutions, etc. for this problem are appreciated. Thanks in advance…

Hi,

Thanks for your support. We have related issue TSS-196 and it may cause a large change. Our developer will consider how to fixed. Thanks again.

Best Regards

Kelly

I am seeing this problem as well. I am running the full developer version of 6.1.0.1759.

Ditto. Running the Toad for SQL Server Professional version of 6.1.0.1759.

Hi all,

I’m a user of TOAD SS 6.1 Xpert edition and I don’t see this problem.

Have you tried new beta version of TOAD SS 6.5 ?

There is a new beta version of TOAD SS posted last week…

Best regard,

Sergio

Yes, I am also experiencing the same error with the same freeware version. I am hesitant to try the Beta version because of the other (apparent) bugs in it.

Anyone found a way to regain the functionality other than closing and reopening Toad? This is the only way I’ve found to get it back.

Any ETA on a fix?

This is a real issue, I have the same issue when I have Read only access to a specific server. I do not have the problem where I am a SA on a development server. This is a bug that has come to light during SS 6.0 and seems to be worse on 6.1 … This needs to be reported and fixed… Another example of improper QA of the product prior to a release, where either new features or existing features are not properly vetted by QA… A Historical fault with Toad SQL Server…

Hank Freeman

Senior SQL Sever DBA - Data and Solutions Architect

Atlanta, GA

Same issue. I can view anything but tables.

Been experiencing the same issue for a while with no way to fix it.

I tried uninstalling and reinstalling and now it happens when I connect to any server.

I’m experiencing this issue as I flip between two databases that I have full permissions on. I also get it when I create a view and then try to go back to the tables within the same database. I have to stop Toad and start it again. 20 or 30 times a day makes this issue quite irritating and a waste of time and resources. Please address this real issue ASAP!

Thank you

Hi Tony,

I tried on the latest beta but didn’t get the error ,Could you please tried the Latest 6.6 Beta?

Could you please give me more details about it ,Could you provide all the permissions you have? Does the table have some special permissions?

We have a issue for this(TSS-196) ,The SQL Dictionary need to be changed so we can fix this issue. This will require a bit of investigation. I will mark this issue as priority 1.We’ll try to figure this out.

Thanks,

Cathy.

Is this going to be fixed anytime soon? I’m having to restart Toad 5 times a day, and that’s with light use on a small database. If I’m creating procedures, it throws this error faster than when I’m inserting data. I love Toad Xpert edition, but have to use the Freeware for personal use, and it never happened on Xpert. Please fix this soon, I love Toad!

Been waiting on a fix for this for months. I believe problem can be fixed IF the DBA grants the View Server State permission to the user. The View Server State permission is needed because “sys.dm_db_index_usage_stats” asks for it (Toad 6.1 uses this)

Luckily I have Toad 6.0 still on my PC that doesn’t have this issue and use it to connect to the servers that cause this problem. My DBA won’t give me the permissions stated above.

Hi,

Thank you very much for your information. We are looking at this.

Best Regards,

Kelly