Toad World® Forums

Cant grant privs to generated file

Our shop has our AD names as "LastName.FirstName". Because of Dot after the last name I get this error when publishing to a secured folder.

Error: Artifact key 'data_lastName.FirstName.O1Daily_Cash_Receipts_Test' contains more than one dot(.) characters.Please quote it using backticks () like: database_name.table_name`.

Because of this I have to publish to only Non-secured folders. (I checked in later versions of Toad and this is not solved although a similar error of loading these types of names into TIC to register them has been solved)

For the most part using an unsecured folder is working fine. But I have one automation script that runs under a service account and generates 300+ reports. At the end of the script I zip them up and upload to TIC. This works for me but when I grant privs to another person to run the script they cannot see or access the uploaded zip file. Any ideas how to solve this? There doesn't seem to be a Public option to these folders. I don't want to make these users Admins.

It turns out there are settings to grant privs on the published file in the automation activity. I assigned them to explicit users and this seems to work. :upside_down_face: