Toad World® Forums

Can't initialize OCI. Error -1

Today I siwtch on the computer and TOAD seems to upgrade itself when I tried to load it. Once the loading process was complete I had lost all my connections and passwords.

So I tried to manually type in the connection details. Each time I get:

Can’t initialize OCI. Error -1

Yes I have looked at other threads but have not found anything relevant.

I’ve unistalled TOAD and loaded back in without any success. The confusing issue is I can use SQL Developer without any issues. So, to my limited knowledge, the clients are OK.

Im not convinced its a PATH issue either since I can run Crystal Reports 2008 (32 bit) without issue and dont want to mess up the configuration.

Any thoughts?

Can you connect via SQL*Plus? SQL Developer doesn’t use OCI to make connections, it uses JDWP so isn’t a valid test of your OCI client.

When I fire the sqlplus.exe the black box appears for an instance and then vanishes.

It does not give you a chance to enter any details.

The only sqlplus.exe I have is the one found in the 11.2.0 client folder.

Cheers

c

Send the contents of your Support Bundle. It’s available from the Help menu within Toad.

Worked it out….thanks for the tip Michael.

Steps taken:

1

Go to TOAD help and click on ‘Support Bundle’

2

Scroll down the information until you find:


ORACLE HOMES DATA


(Oracle Root)

inst_loc = C:\Program Files\Oracle\Inventory

KEY_OraClient11g_home1 ***** This is the home currently used by Toad *****

ORACLE_HOME = C:\ORACLE\ORA_11g_FULL\11.2.0\Client_1

3

Im using ‘Windows 7’…………….Go to the Control Panel Home and click on ‘Advanced system Settings’.

Click on ‘Environment Variables’.

If you don’t have an ORACLE_HOME create one. If ORACLE _HOME exists make sure it is the same as the ORACLE_HOME in the ‘Support Bundle’.

Close all instances of TOAD and open up another one.

I was able to log into my databases. NOTE: I have not done a full test, yet.

This goes to inform my opinion that Microsoft SQL Server is a superior product to anything ORACLE can supply.

Go figure out this!

When I changed the ORACLE _HOME other applications stopped working. So I changed the ORACLE_HOME back to its original value.

I fully expected TOAD to fail i.e. fail to connect to the databases, but it did not. I have been able to connect to all the databases and my other applications are working.

I have no idea what went wrong and why changing ORACLE_HOME makes TOAD work.

I also dont have any idea why changing the ORACLE_HOME back to its original value still allows TOAD to work.