Toad World® Forums

Can't initialize OCI. Error -1 (only on Windows 7)


#1

Hi,
I’m experiencing a problem using Toad 10.6 for Oracle Freeware on PC.

I use Oracle Client 10.2.0.1.0

It works fine on Windows XP, but on Windows 7 I have the error message “Can’t initialize OCI. Error -1” during the connection attempt.

Can anyone help me?

Thanks.

Sergio Valerio


#2

Hello,

Are you on 64-bit Windows? If so, check your Oracle client software and make sure you don’t have the 64-bit version installed. Toad does not work with 64-bit Oracle client. I’ve also seen this error when the Oracle instant client is not setup properly.

Brad


#3

It doesn’t work.
I’ve unistalled 64-bit client Oracle and have installed 32-bit version.

Same error message


#4

There is a known Oracle bug with certain Oracle 10g clients that may cause this. Which version did you install? The latest 10gR2 patch and 11g don’t have this problem.


#5

I’ve installer 10.2.0.1.0
10.2.0.4.0 is only 64bit

This is my configuration and it seems to be correct

SOFTWARE\WOW6432NODE\ORACLE\KEY_ORACLIENT10G_HOME1
ORACLE_HOME_NAME: OraClient10g_home1
ORACLE_HOME: C:\Oracle\product\10.2.0\client_1\instantclient
ORACLE_SID:
NLS_LANG: ITALIAN_ITALY.WE8MSWIN1252
SQLPATH: C:\Oracle\product\10.2.0\client_1\instantclient\dbs
LOCAL:
C:\Oracle\product\10.2.0\client_1\instantclient\Bin exists.
C:\Oracle\product\10.2.0\client_1\instantclient\Bin is in PATH.
Client DLL: C:\Oracle\product\10.2.0\client_1\instantclient\Bin\oci.dll
Client Version: 10.2.0.1.0
Home is valid.


#6

Quest Support has a great knowledge base from previously reported user errors. This is a frequent error so you should find exactly what you’re looking for here…

https://support.quest.com/Search/SearchKnowledgebase.aspx?dsNav=Ntk:all_internal|can’t+initialize+OCI+Error|3|,N:268435520&Dt=Toad%20for%20Oracle

Most likely your issue…

https://support.quest.com/Search/SolutionDetail.aspx?id=SOL12495&category=Solutions&SKB=1

https://support.quest.com/Search/SolutionDetail.aspx?id=SOL61710&category=Solutions&SKB=1


#7

I’ve just tried to install last patch, but it doesn’t work.

SOFTWARE\WOW6432NODE\ORACLE\KEY_ORACLIENT10G_HOME1
ORACLE_HOME_NAME: OraClient10g_home1
ORACLE_HOME: C:\Oracle\product\10.2.0\client_1\instantclient
ORACLE_SID:
NLS_LANG: ITALIAN_ITALY.WE8MSWIN1252
SQLPATH: C:\Oracle\product\10.2.0\client_1\instantclient\dbs
LOCAL:
C:\Oracle\product\10.2.0\client_1\instantclient\Bin exists.
C:\Oracle\product\10.2.0\client_1\instantclient\Bin is in PATH.
Client DLL: C:\Oracle\product\10.2.0\client_1\instantclient\Bin\oci.dll
** Client Version: 10.2.0.3.0Patch2
Home is valid.
**
Now I try to install 11g client release.

If also this solution fails, I think I’ve to uninstall W7 and re-install XP!
This problem is annoying myself too much…


#8

Is this Windows 7 64 bits?

If so, don’t install XP again. What you must do is rather simple.

Don’t install an Oracle 64 bit client. Those are problematic. Install a 32
bit client instead.

Install Toad into a directory where there are no () in the path name like
C:\Program Files (x86)\ . There is a bug in the Oracle client you use which
leads to errors if the application had () in the name.

or

Install Oracle 10.2.0.4 32 bits. That one has the problem removed.

or

Install Oracle 11 32 bits Don’t know any subversions there, but all of them
hasn’t this problem.

Groetjes,
Wim

On Wed, Mar 23, 2011 at 10:24, {Toad for Oracle} on behalf of


#9

Hi Wim,
I’ve done all your suggests, but the problem remains.

But I’ve found the reason of the problem.

If I run Toad as a domain user with “Administration” privileges on local machines I’ve the problem.

If I run Toad as local Administrator user of my PC, I connect to Oracle successfully.

So it’s only a problem of privileges!

It’s strange: my domain login ENTERPRISE\valeriose has admin privileges on my pc but with this user Toad fails with error “Can’t initialize…”
I’ve also attempted “Rus as Administrator” by contextual menu but without success.

If I use my local user “MYPC\valeriose” that is local administrator Toad connect to Oracle!

Any suggest to use Toad with my domain login?


#10

Ok, I’ve solved.

I’ve found a problem in environment variables.

ORACLE_HOME was set to C:\Program Files\Oracle…
but I’ve installed the client in C:\Oracle…

I’ve modified the env variable and now it works fine!

Thanks to all.
Sergio


#11

Thanks for the direction that helped me to solve the similar problem. I found that you need to lower the setting of the User Account Control in Windows 7 64-bit PC. (for the Windows 7 32-bit, I didn’t have any issue using TOAD (V. 9.6.1) at all, even the default User Access Control was set on the top 2/3 position). To lower the User Account Control, go to the Control Panel, under the Action Center, click on Change User Account Control settings and drag the bar down to the bottom. You can open TOAD as whatever user now.

In summary, I install the TOAD in C:\Quest Software (don’t take the default path ‘Program Files (x86)’). Lower the User Account Control.


#12

Thanks! That really ehlped me. I was banging my head aghainst the wall tryign to figure this out.


#13

Ya, Thanks a lot powong!

Solved my problem after about a month!