Toad World® Forums

Can't see created PostgreSQL ODBC connection in the drop down list in Toad Data Point (4.3)


#1

Hello

I have created an PostgreSQL ODBC connection but I can’t see it in the drop down list via application. Please advise.

[View:/cfs-file/__key/communityserver-discussions-components-files/36/ODBC–connection-2D00-Toad-Data-Point.docx:320:240]


#2

There are a couple of reason this might be.

  1. There are two ODBC managers. 32-bit and 64-bit. Did you define the DSN in the ODBC manager that is the same bitness as Toad? 64-bit Toad can only use 64-bit DSNs and drivers.

  2. Is your DSN name really long? One users says that when his DSN name is really long it does not show in our list.

  3. Did you define as user or system? I prefer system as this scope is wider, however this would only be a problem if you created DSN under one logid and then logged on as another.


#3

Let me try “easiest” route first :slight_smile:

How did the user resolve this: 2) Is your DSN name really long? One users says that when his DSN name is really long it does not show in our list.


#4

I entered QAT-12439 for DSN too long and not showing up. They were using this name “Sample Hortonworks Hive DSN_Prod”. They just made a shorter name to get it to show up. But i cannot reproduce this issue even using this same ODBC driver. So I have my doubts about length of name being an issue.

I had another idea. There is an option under Database | ODBC to filter out DSNs based on architecture. This is on by default. Try unchecking that and see if that fixes. Maybe we are mistakenly recognizing the bitness of your drivers.


#5

Hi Debbie

thank you so much for your prompt replies. Your suggestion worked in terms of seeing the very long name. However I am getting an error message.

[View:/cfs-file/__key/communityserver-discussions-components-files/36/error.docx:320:240]


#6

I need to see the DSN description and how you are connecting with it. Post pictures. But we might need to have you open a support case.


#7

Hi Debbie

attached file contains step by step set up views. all the way at the bottom of the document I have put my “guess” on what is happening in RED (I might be completely wrong).

Please advise. And thank you for your continuous[View:/cfs-file/__key/communityserver-discussions-components-files/36/Long-name-ODBC–connection–set-up-Toad-Data-Point.docx:320:240] support.


#8

I see two points here.

  1. I am pretty sure that the Data Source name is just a display string and can be anything. It does not have to be the name of the server. Try using the Data Source attribute as a display name.

  2. You can uncheck the “Use Datasousrce Name” and define a connection manually.

Note: We are adding a few new features for PostgresSQL in the next release. One of them will be to define a connection without having to create a ODBC dsn[H]


#9

Hi Debbie

I have followed your suggestions. Neither worked ([:’(]). See attached file.

Would you know when next release is?

thanks.


#10

I can reproduce the issue of long DSN name not showing in the list but if I don’t have a long server name so maybe this is also the issue.

can you try NOT using DSN. See this screenshot. Uncheck using DSN. Then pick your driver, fill out user and pass work and then enter connection string with the three options I show below using same syntax. If it does not work still, post screenshot of error and how you have filled out the connection dialog.


#11

Hi Debbie

I have a hunch that after exhausting all the option with connectivity (with an extensive assistance from you [:D]) the issue might be our company internal. Please do not close this conversation yet. I am currently working to see if I am right. For now I don’t need any other assistance from your side. You have been awesome as always.


#12

The recommended approach is to use a ODBC Data Source. Please refer community.toadworld.com/…/using-postgresql-database-on-localhost-with-toad-data-point


#13

Hi Debbie

I have tried everything with our internal group. The issue seems to be with Toad. I did everything from the suggested link you’ve sent) and still cannot connect. Getting error message on Figure 25 from that link. Should I open Helpdesk request with Quest.

Please advise.


#14

I haven’t see the help ticket yet. what is the number? We are working on QAT-12439 in this current sprint. When done i think it best to send you that fix and then go from there. if you can post the support case number I will keep an eye out for it.