Toad World® Forums

Issue with creating connection to PostgreSQL

Hello

on numerous occasions I have successfully created ODBC connections (first through MS ODBC Administrator) then in Toad Data Point (version 4.1) to the multiple PG databases.

I am creating a new one now a PG database. I can successfully create a connection via MS ODBC Admin as well as connect to it via PG Admin. But when I try to create a connection via Toad App (using same exact steps as previously) I am getting an error (see screenshot). Please advise. thank you. Screenshot_1.jpeg

Try saving your username and password in the DSN. Then with TDP do not enter username or password. Just point to DSN name.

Thank you Debbie. I will do that going forward

My co-workers actually helped me solve the issue just this morning by following: The password contains %. When I have replaced it with %25 Toad has accepted it.

I am not sure why that would have fixed it. Did you try my idea? If it would save in the DSN and work but not work when entered to TDP then the error is on our side. I’ll enter a bug if you can confirm which it is. We are adding some enhancements for PostgresSQL next release so this would fit the Epic.

I have created it originally as User DSN and saved. I had no problem connecting there with regular password (with % sign). Toad still requires UN and PW. so I had to replace % with $25.

Replacing % with $25 makes senses. I’ll enter an issue for this. thanks.QAT-11185

Sorry. it was %25, not $25.

Hi Debbie

could you please let me know if this issue was resolved. With new internal security measures I am encountering this issue on regular basis. Greatly appreciated.

We are planning long list of enhancements for PostgresSQL in theTDP 4.5 release. So I scheduled that fix for that release.

I took a second look and I will see if i can get your fix in the TDP 4.3 release due out Nov.

Thank you Debbie. Is this fix going to be valid for connections to all databases? I’m currently experiencing issues with Oracle. Same issue - special characters in password.

Greatly appreciated

Lyuba Michel

On Sep 19, 2017, at 1:30 PM, Debbie Peabody bounce-Debbie_Peabody@toadworld.com wrote:

RE: Issue with creating connection to PostgreSQL

Reply by Debbie Peabody
I took a second look and I will see if i can get your fix in the TDP 4.3 release due out Nov.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad Data Point Forum
notifications altogether.

Toad Data Point - Discussion Forum

Flag
this post as spam/abuse.

Each provider is coded separately. I can ask that the dev support this for Postgres and Oracle

i have a fix for this password issue for Oracle and PostrgresSQL. We found that passwords with special chars need to be surrounded by symbols that allows it to be passed through. For PostgresSQL those chars are {…} We have added this to the code and you do not need to include. However, for other databases these chars are different. IE: [], “…”, etc. For other platforms you need this to work we just need to find out what that char is and surround the password. So if you expand to other database types you will be able to do this manually.

Here is the fix. Can you download and confirm it works for you?

http://community-downloads.quest.com/toadsoft/tda/ToadDataPoint_pro_4.3.0.638.x64.zip

P.S. Hope you use 64-bit as i only built that version.

Hi Debbie

I apologize for late reply. Thank you for providing me with possible solution. I have downloaded the application you have provided. It created another problem - TNS error message. This version of application doesn’t work with any Oracle connections. Also it doesn’t see any ODBC connections. Any suggestions?

[View:/cfs-file/__key/communityserver-discussions-components-files/36/3513.Doc1.docx:320:240]

I don’t see how the TNS error relates. Do you usually run a 32-bit app? This would explain why you don’t see any ODBC connections as DSNs are registered as 32-bit or 64-bit and they cannot be mixed and matched. i will be posting a final Beta tomorrow. The Beta will offer 32 bit and 64 bit. Let’s have you download that and try.

P.S. The Beta needs to be build 638 or greater. So you will need to wait for tomarrows Beta. But here is the link to make it easy to access

http://www.toadworld.com/products/toad-data-point/toad_data_point_beta_program/

The Toad World Beta page won’t get updated until Monday. But you can download from the url below.

http://community-downloads.quest.com/toadsoft/tda/ToadDataPoint_Beta_4.3.0.702.zip

Hi Debbie

could you please let me know what version of Toad Data Point has this resolved. I have been asked by our IT Ops team to resolve this issue within next 30 days as our security policy for passwords has been changing and became more strict.

Greatly appreciated

This fix is in the GA version of Toad Data Point 4.3. You can download upgrade from here.

https://support.quest.com/toad-data-point/4.3/download-new-releases

Hi Debbie

thank you so much for your help. I have tried as you have suggested (copy of email below) to surround password in Oracle by “…”, {}, […]. Nothing worked. Please advise.

"i have a fix for this password issue for Oracle and PostrgresSQL. We found that passwords with special chars need to be surrounded by symbols that allows it to be passed through. For PostgresSQL those chars are {…} We have added this to the code and you do not need to include. However, for other databases these chars are different. IE: [], “…”, etc. For other platforms you need this to work we just need to find out what that char is and surround the password. So if you expand to other database types you will be able to do this manually.

"