Toad World® Forums

Changing system variables results in Toad Data Point 4.2 not loading

I am new to the forum. Let me know if I should post this elsewhere.

I'm running two Oracle clients:

  • Oracle 12.2.0
  • instantclient_19_5

I use the instant client for an odbc connection via RStudio, but after installing the instant client and adding it to the PATH environment variable the launcher just pops up and closes. The issue seems to resolve if I remove the instantclient directory from PATH. Is there any workaround? I can't find ORACLE_HOME in the registry for 12.2, do I need to create it?

I'm on windows 10 (64 bit).

The stack trace is not registering any events.

If it's useful here's the details from AppData\Local\Quest Software\Quest.Tech

11:36:12 AM: Begin Constructor
11:36:12 AM: Constructor: Initialize Variables
11:36:12 AM: Constructor: Get System Info
11:36:12 AM: Constructor: Initialize Resources
11:36:12 AM: Constructor: Create Wrapper Domain
11:36:12 AM: Constructor: Save DLLs
11:36:12 AM: Constructor: Build Wrappers
11:36:12 AM: Constructor: Get Current Day
11:36:12 AM: Exit Constructor

Couple things come to mind...

  • Are you choosing the correct Oracle client home in Toad Data Point's Oracle connection profile? See snap below.

  • Check the release notes for Oracle Client, but you may need to create that Oracle_Home variable.

The correct driver is loaded for connections. To be clear I can't get the Toad Data Point software to load at all unless I remove the instant client directory from the PATH. My curremt solution that seems to work is simply placing the instant client after OraClient in PATH.

I couldn't find anything on setting the Oracle_Home variable, but I had to manually set them for instant client due to some weird installation issues. I will try setting it in regedit. Does the Oracle Home need to point to

  • C:\Oracle12cR2\product\12.2.0\client_1
    or
  • C:\Oracle12cR2\product\12.2.0\client_1\bin

Yes, ordering the locations in your PATH and xHOME env variables will help, and I forgot to mention the obvious (putting the path to the full Oracle Client before Instant) which you've already done.

ORACLE_HOME, if needed, should point to the directory just above the bin dir, so your first bullet.

For those who run into issues like this. Reordering the PATH did not work after restart. I had to delete the instant client directory from PATH to get Toad to load. Luckily, I'm still able to use ODBC applications that were already setup. I'm not sure what the issue is, but my guess is that when Toad is installed greater specificity is needed when directing to the appropriate oracle driver. Unfortunately, I'm unable to reinstall toad without IT permissions at work, so this is my temporary fix until it breaks again.

Got a new computer at work and this issue replicated on the new system. Upon further testing most ODBC applications that use the instant client don't need the instantclient directory in PATH to function, but some do. Pretty annoying issue as I have to edit the PATH every time I want to switch between VS code and Toad DP. Detrimental to users who don't have those permissions.