Toad World® Forums

Invalid Oracle_Home in Toad for Oracle Xpert Trial (32bit) DBA Edition 13.0.0.80


#1

Dear all,

I have downloaded the above Version of TOAD for Oracle but cannot manage to connect to my database(s) due to invalid Oracle Home Error.

I have found a lot of hints and Solutions in here about that but none works.

my Oracle Client and Toad are installed on an application Server and the Oracle 11g Client 11.2 is installed on drive D:. I do not expect that this is any Problem but I receive the error of "

Invalid Oracle Home: D:\oracle\product\11.2.0\client_1\BIN". I already read that it may be wrong that the \bin subdirectory is mentioned but in TOAD itself I cannot find any Setting how and where to Change this. In my registry the Oracle-home is set correctly without the \bin mentioned. It seems strange to me, that in toad my two databases I work with are already named (maybe remained from a former Trial Installation… (?) but the Connection does not work).

Can someone help me out and advice???

Thanks a lot…


#2

Any new ideas ???

I am not able to work/test Toad if this is not solved… Thanks.


#3

D:\oracle\product\11.2.0\client_1\BIN should be in path env variable.

Oracle home should be:

D:\oracle\product\11.2.0\client_1

Try this…in command prompt place:

set ORACLE_HOME=D:\oracle\product\11.2.0\client_1

set PATH=D:\oracle\product\11.2.0\client_1\BIN;%PATH%

(Program Files (x86)…)toad.exe

in this way you should be certain that all is (from otracle env OK).

If you get an error, then show it as well IN OTHER COMMAND PROMPT, place results from “set” command.

Brg

Damir


#4

Dear Damir,

thx for your kind answer, checked my settings, they look as suggested.

But still I have same error in toad (Invalid Oracle Home: D:\oracle\product\11.2.0\client_1\BIN)

.

This is how my Instant-Client settings look like in Toad:

Instant Client - 11.2.0.3 (11.2.0.3)

ORACLE_HOME:D:\oracle\product\11.2.0\client_1\BIN

ORACLE_HOME_NAME:D:\oracle\product\11.2.0\client_1\BIN

ORACLE_HOME_KEY:

ORACLE_SID:

NLS_LANG:

SQLPATH:

LOCAL:

Client DLL:D:\oracle\product\11.2.0\client_1\BIN\oci.dll

TNSNames.ora:D:\oracle\product\11.2.0\client_1\Network\Admin\tnsnames.ora

SQLNet.ora:D:\oracle\product\11.2.0\client_1\Network\Admin\sqlnet.ora

LDAP.ora:D:\oracle\product\11.2.0\client_1\Network\Admin\ldap.ora

Login.sql:

GLogin.sql:

In system PATH:Yes

Home is valid:Yes

There the Oracle_home is wrong but I cannot change this setting in toad itself, the text is not editable.

Sorry but I really do not understand what is going on L

Do I need to reinstall TOAD???

Regards KUCHP


#5

I don’t think reinstalling Toad is going to change anything.

When I have client problems this is what I do and it always seems to work for me:

  1. uninstall all oracle clients

  2. reboot

  3. make sure that the registry hive HKLM\Software\Oracle is gone

  4. reinstall the client that I need (ideally, only one client, make sure that it is 32 bit if that’s what your Toad is).

  5. if you need more than one client installed, then install them in order from oldest to newest.


#6
  1. can you run mine advice?

  2. when you run “sqlplus /nolog” (from command prompt) do you get staretd oracle app?


#7

Go to Help|Support Bundle and post the contents here. Or, you can email them to me directly at michaelstaszewskiquest.com if you’d like. The data there is mostly free of sensitive data, but does show user profile paths which will include your OS username, etc.

Thanks,

Michael


#8

Dear John, thanks for your answer but reinstalling the Oracle client is not possible for me. Regards KUCHP


#9

Dear Damir,

yes to both and thanks again.

That means the Oracle-Home and path env variabls are set as suggested by you and yes I could successfully start sqlplus from command prompt.

Regards KUCHP


#10

Dear Damir,

yes to both and thanks again.

That means the Oracle-Home and path env variables are set as suggested by you and yes I could successfully start sqlplus from command prompt.

Regards KUCHP


#11

Dear Damir,

thx for your kind answer, checked my settings, they look as suggested.

But still I have same error in toad (Invalid Oracle Home: D:\oracle\product\11.2.0\client_1\BIN)

.

This is how my Instant-Client settings look like in Toad:

Instant Client - 11.2.0.3 (11.2.0.3)

ORACLE_HOME:D:\oracle\product\11.2.0\client_1\BIN

ORACLE_HOME_NAME:D:\oracle\product\11.2.0\client_1\BIN

ORACLE_HOME_KEY:

ORACLE_SID:

NLS_LANG:

SQLPATH:

LOCAL:

Client DLL:D:\oracle\product\11.2.0\client_1\BIN\oci.dll

TNSNames.ora:D:\oracle\product\11.2.0\client_1\Network\Admin\tnsnames.ora

SQLNet.ora:D:\oracle\product\11.2.0\client_1\Network\Admin\sqlnet.ora

LDAP.ora:D:\oracle\product\11.2.0\client_1\Network\Admin\ldap.ora

Login.sql:

GLogin.sql:

In system PATH:Yes

Home is valid:Yes

There the Oracle_home is wrong but I cannot change this setting in toad itself, the text is not editable.

Sorry but I really do not understand what is going on L

Do I need to reinstall TOAD???

Regards KUCHP

Von: Damir Vadas [mailto:bounce-damirvadas_250@toadworld.com]

Gesendet: Donnerstag, 17. Mai 2018 12:08

An: toadoracle@toadworld.com

Betreff: RE: [Toad for Oracle - Discussion Forum] Invalid Oracle_Home in Toad for Oracle Xpert Trial (32bit) DBA Edition 13.0.0.80

RE: Invalid Oracle_Home in Toad for Oracle Xpert Trial (32bit) DBA Edition 13.0.0.80

Reply by Damir Vadas

D:\oracle\product\11.2.0\client_1\BIN should be in path env variable.

Oracle home should be:

D:\oracle\product\11.2.0\client_1

Try this…in command prompt place:

set ORACLE_HOME=D:\oracle\product\11.2.0\client_1

set PATH=D:\oracle\product\11.2.0\client_1\BIN;%PATH%

(Program Files (x86)…)toad.exe

in this way you should be certain that all is (from otracle env OK).

If you get an error, then show it as well IN OTHER COMMAND PROMPT, place results from “set” command.

Brg

Damir

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle Forum
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.


#12

Dear John, thanks for your answer but reinstalling the Oracle client is not possible for me. Regards KUCHP

Von: John Dorlon [mailto:bounce-jdorlon@toadworld.com]

Gesendet: Donnerstag, 17. Mai 2018 14:55

An: toadoracle@toadworld.com

Betreff: RE: [Toad for Oracle - Discussion Forum] Invalid Oracle_Home in Toad for Oracle Xpert Trial (32bit) DBA Edition 13.0.0.80

RE: Invalid Oracle_Home in Toad for Oracle Xpert Trial (32bit) DBA Edition 13.0.0.80

Reply by John Dorlon

I don’t think reinstalling Toad is going to change anything.

When I have client problems this is what I do and it always seems to work for me:

  1. uninstall all oracle clients

  2. reboot

  3. make sure that the registry hive HKLM\Software\Oracle is gone

  4. reinstall the client that I need (ideally, only one client, make sure that it is 32 bit if that’s what your Toad is).

  5. if you need more than one client installed, then install them in order from oldest to newest.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle Forum
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.


#13

Dear Damir,

yes to both and thanks again.

That means the Oracle-Home and path env variabls are set as suggested by you and yes I could successfully start sqlplus from command prompt.

Von: Damir Vadas [mailto:bounce-damirvadas_250@toadworld.com]

Gesendet: Donnerstag, 17. Mai 2018 15:45

An: toadoracle@toadworld.com

Betreff: RE: [Toad for Oracle - Discussion Forum] Invalid Oracle_Home in Toad for Oracle Xpert Trial (32bit) DBA Edition 13.0.0.80

RE: Invalid Oracle_Home in Toad for Oracle Xpert Trial (32bit) DBA Edition 13.0.0.80

Reply by Damir Vadas

  1. can you run mine advice?

  2. when you run “sqlplus /nolog” (from command prompt) do you get staretd oracle app?

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle Forum
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.


#14

This means quite opposite-you have INVALID ORACLE_HOME!
If you start toad from command line with proposed env, you have done all needed for running Toad.
If then you have invalid ORACLE_HOME, then something is wrong …

  1. coulp you place logs from runing sqlplus from command prompt?
  2. could you execute sqlplus /nolog and shows what you have in command prompt?
  3. could you return output of the “SET” command from command line…

If all previous is OK, I suspect some security problems when installing or running on you PC or some registry invalidation.
So i would propose to run from command prompt and look in log.
sfc /scannow.


#15

If this is still an issue, please open a support case. Our support is well versed in Oracle client setup.


#16

Dear all, thx, I will open a Support case but Need to wait until Wednesday due to serve maintenance. I will Keep you updated.

Regards from KUCHP.