Changing UI colors

Hello guys, I am interested to know whether or not it’s possible to change the Toad UI colours?

I’ve already changed the DataGrid and Editor ones, however I’m yet to find a way for me to change the Window/menu/toolbar colours as well.

Is there currently a way to do that? Perhaps by digging into some config file or something?

Thank you!


Sorry, there is no way to change the color theme of Toad overall, just individual components as you mentioned

Actually, you can change the visual style if that helps, go to options > toolbars/menus > toolbars and see the “visual style” dropdown

Hey there, the closest thing that matches my preferences is office 2003… sadly the background is still white =(

Guess I will wait for such a feature! Thank you for the response!

Please submit your idea in the idea pond (if it is not already there, in which case you can vote for it……/i

Background of what is still white? If you mean the Window color then change that in Windows are you would normally. With the exception of toolbars, data grid, and syntax decoration the other component colors are largely controlled by the operating system.

Hey, you are right that Windows itself controls most of the colours.

However I was looking for a more unified type of setting that resembles the colour-theme I’ve set up on my editor/data grid without it being intrusive into my other windows (non-toad related).

I will take a look at the Idea pond as you suggested!

Apart from the standard controls, if you’re trying to set the editor background to a different color this can be done by changing the Background color of the Default style on the Editor|Font and Styling page in Options. In case you haven’t found that. This is one setting that deviates from Windows system color since your syntax decoration may necessitate a different background color.

Hy i chaged the colors exepted the '*',';' who stayed in black and according thaht the background is black that's an issue .
Can somebody help me by explaining how to change the color of those caracters ??


In Options select Editor > Font and Styling page on the left. On the right select the SQL language tab and then its Styling tab. Change the properties of the Symbol class.

Tank's a lot mstaszew , but i don't have this option, i've got TOAD

Go to the Syntax highlighting options dialog...

...and change the "Symbol" style font color...


thank you very much i found the solution the problem was that the * and ; were not in the parse for the symbol , this way there were not take in account, i added them and it worked.
Anyway thank a lot !!!

Le jeu. 27 juin 2019 à 16:03, Michael Staszewski via Toad World® Forums a écrit :