Toad World® Forums

Connection Continuously Drops


#1

I have been using TOAD for Oracle Freeware version 10 for a while now and have never experienced a dropped connection.

I was recently issued a licensed version of TOAD for Oracle version 10.5.1.3. Ever since I installed the licensed version I have been receiving an ORA-03135 error when my app sits idle for a few minutes. I never received this error on the freeware version.

My Oracle client version is 10.2.0.1 and we are connecting to an Oracle 10g database. I tried adding the following entry to my sqlnet.ora file:

SQLNET.EXPIRE_TIME=60

This has not fixed the issue. I’m also connecting with the same account that I was using on the freeware version. Thank you in advance for your help.


#2

Check with your DBA – they may have instituted using Oracle profiles to
auto logout people after N minutes of inactivity – and there’s
nothing toad can do to circumvent that


#3

Attached is a screenshot of the error I’m receiving
ORA-03135.png


#4

Can you re-install the freeware and see if it suffers the same problem now?

Also, can you connect via SQL*Plus – making sure to do so from the same
ORACLE_HOME?


#5

I can connect via SQL*Plus from the same ORACLE_HOME.

Can I install the freeware without clobbering my licensed version?


#6

Yup.


#7

I finally had a chance to re-install the free version of Toad for Oracle and connected to my database and did not receive any of the connection issues I’m seeing with the Commercial version. I left my session idle at least half the day and when I started using Toad again it worked flawlessly without displaying the message of the connection being dropped.


#8

I wonder if there is a database trigger or job that is looking for toad
connections and killing them. I think the freeware version shows up in
V$SESSION differently in the MODULE column.

It’s probably something much more benign, but that’s the first thing
that jumped into my mind.


#9

I will check with my DBA to see if this is the case