Toad World® Forums

toad freeware 10.5 expired... how do i renew it?

My freeware version expired today can I renew it? I’m getting the message “This version of Toad for Oracle has expired. You must download a new version before proceeding.”

I’ve tried downloading beta 10.6 but I’m still getting a error message.

I got the same message today for 10.6. Did you solve the problem?

I am also experiencing the same for 10.6; downloading new file does not resolve the issue.

Same for me today 10.6 update file is not removing the expiry message. Guessing the downloadable exe needs updating?

Chalk me up as another 10.6 freeware user that is unable to update without getting a expired notice.

Same Problem!

I’m having the same issue as well.

I found some Quest/Toad entries in the registry after the uninstalling the previous installation, but removing them manually didn’t help anything.

The expiration is hard-coded into the executable, you can’t get around it or
renew it by doing anything locally.

really ?

then why when i change the date of my computer i can lauch toad ?

You “can” but doing that would violate the terms of the freeware license.
image001.png

You also can screw up most AntiVirus programs by changing your date – it
can mess with their update downloads process and expose you to stuff ….
image001.png

I am also unable to renew my toad for oracle freeware with the update that is posted. Will a correct version be posted?

Because it compares the date on your computer with the date hard coded in the
executable.

If you are an Oracle professional and you really want to proceed in that manner,
then by all means, go for it. If it were up to me I would remove the expiration
date permanently. All it does is make extra work for us to have an expiration
period, and serve up highly questionable data to Quest.

I don’t think these problems are related.

The freeware version is supposed to be licensed for 90 days, right?

Mine stopped working after 25 days +/- 0.5 days.

I.e. I installed it on 24th Feb 2011 early am GMT, it stopped working some time between about 19:00 GMT on Sunday 20th Mar 2011 and early am GMT on Monday 21st March 2011. It’s possible it stopped working after precisely 25 days, I can’t be certain, but I doubt it because I think it first failed before the time I installed it. But even if it did, 25 days is not the correct license period. It seems several other people got the same error message at the same time and we can’t have all installed it on the same day.

I’ve come up with a hypothesis which might explain this:

Maybe Quest set the expiry dates in the executable before they distribute it to sites you can download the freeware version from.

So you don’t get 90 days from when you install it, you get 90 days from when the distribution file was built.

Then if the site you got it from has not been updated since it does not help if you un-install, clear cached files, or whatever, because when you download it again it has already expired.

Does anyone know if I’ve guessed right? If so does anyone know which site is updated first, because I can’t find it on Quest?

correct Jon

download it via ToadWorld

I have the same problem with version 10.6 today? does anyone know how to renew the preriod? the License Agreement says that it can be downloaded again but it doesn’t work.

The Toad for Oracle Freeware version may be used for a maximum of five (5) Seats within Customer’s organization and expires each ninety (90) days after the date of its initial download (“Freeware Term”). Upon expiration of the Freeware Term, the same 5 Seats may be downloaded again by the same users for the Freeware Term. For more than five (5) users within an organization, Customer will need to purchase licenses of Commercial Toad for Oracle. This license does not entitle Customer to receive hard-copy documentation, technical support, telephone assistance, or enhancements or updates to the Freeware from Quest. The terms “Seat” and “Freeware” shall have the same meaning as those set forth in the Product Guide located at www.quest.com/productguide.

Regards,

MFM

Please tell us exactly what you tried so we know where you are going wrong

Example:

Steps

1 – Download update

2 – Puts down new exe

3 – Put in toad free directory

4 – Rename to ‘toad.exe’

5 – Run it

I have just downloaded Toad 10.6.1.3 and am trying to view my database schemas.
However when I choose Schema Browser, it displays all fields as little empty
boxes, instead of letter/numbers. Does anyone know which display/view setting I
must change? Or perhaps it’s a field in my 10.2.0.4 database. I can get
into SQL Developer fine and into SQL Plus as well. This is a Windows XP
environment.

Thank you for the help.

James W. Wolff

PA Department of Conservation and Natural Resources
Bureau of Information Technology Services

400 Market Street | Harrisburg, PA 17105
Fax: 717.772.9107
E-mail: c-jwolff@state.pa.us

www.dcnr.state.pa.us

This usually means your Oracle client is too old. Download a new one from Oracle
and be sure to select in the “connect using” dropdown on
Toad’s login screen.