Toad World® Forums

Toad12.11.0.95 logging off database

If I do not use Toad for more than a few minutes, when I go back and recompile something it tells me I’m logged off and I have to reconnect. I did not have this issue with the evaluation copy I was using before we got our licenses.

Hi Jim,

I sent an email reply to this query yesterday, but it doesn’t seem to have appeared yet - maybe it’s still in moderation somewhere.

There are a number of reasons why your connections are dropping out:

  • The network is configured (or mis-configured) with at least on switch, router or firewall having a time to live (TTL) setting;
  • The network has a faulty component somewhere;
  • The database login uses a profile which has an IDLE_TIME set to log you out (and rollback etc) after a given time of idleness (or thinking!);
  • Windows 7 and higher, has a feature whereby it will disconnect the WiFi network connection after a period, to save power. This only applies if you are on WiFi of course, but it has affected me in the past.
    I have suffered from most of the above in the past, I think I’ve only missed out on the faulty network component.

If the network is mis-configured then your network team will need to find it and fix it. If the database login is affected by a profile, then good luck getting that changed as it could be an instruction from “on high” to keep the database clean of idle sessions.

Until the network team get their act together (and I’m speaking from experience) your workaround is to set the “SQLNET.EXPIRE_TIME” to a small number of minutes, say 15, in the sqlnet.ora on the database server. That will send a probe from the database to keep any open connections working, while getting rid (or helping) those that are definitely dead connections.

In my last contract I suffered from a switch being configured with a 15 minute idle time. That’s fine, but if I submitted a long running query (and one I was optimising took 54 minutes originally) then while Oracle was still working, the network dropped my connection, resulting in an inability to test any changes, plus a lot of “interesting Scottish Swearing”. SQLNET.EXPIRE_TIME was set to a time (in minutes) less than the 20 minutes that they had set - I used 15. That stopped the problem and when I finished that contract, the network team still had not changed the setting!

Obviously you need to set this less than the timeout you are suffering from.

It is unlikely to be Toad, however, you can go to View -> Toad Options and do a search for delay, timeout, network etc, and see if there are some settings that might be being used in the GA version of Toad that may not have been used in the evaluation version that you used previously.


Hi Jim,

Mysterious logoffs from the database can be caused by a number of things:

A flakey network, which can drop your connection to the database server occasionally;

A time to live (TTL)setting on a network component, switch or router etc, or in a firewall rule, which kills your connection after aperiod of inactivity;

The profile of the user that you are logged in to on the database might have been set up to drop your connection after a given idle time period. Speaking as a dba, these cause more trouble as all uncommitted transactions get rolled back - double the database work for no gain;

Windows 7, onwards, can shut down wifi connections if they are idle for too long too. If you are on wifi of course;

Something else?

It is unlikely to be a Toad problem. You could check with view->options then search for anything timeout or delay related, just in case, but I don’t recall any such settings.

I have suffered from all of the above over the years. You can get around the TTL problem by a setting in the database servers sqlnet.ora file, I can’t remember it offhand (I’m in bed!) But you or your dba should be able to find it - assuming of course, that the network has been accidentally mis-configured with a TTL, and not deliberately set up that way.



Norm. [TeamT]

On 5 October 2017 20:26:47 BST, jimhope wrote:

Toad12.11.0.95 logging off database

Thread created by jimhope
If I do not use Toad for more than a few minutes, when I go back and recompile something it tells me I’m logged off and I have to reconnect. I did not have this issue with the evaluation copy I was using before we got our licenses.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or Unsubscribe from Toad for Oracle Forum notifications altogether.

Toad for Oracle - Discussion Forum

Flag this post as spam/abuse.

Sent from my Android device with K-9 Mail. Please excuse my brevity.

If all before did not helped you, please notice this.
I saw many corporates that they have rule to kill sessions that comes from “Toad.exe” automatically.
So, try to rename Toad.exe to “MyFroggy.exe” and then restart Toad.
if this doesn’t solve your problem, ask your DBA to see if they are doing something nasty…or Networkk guys (soem changed rule on firewall).
I assure you that Toad is not killing session without reason.