Toad World® Forums

<Connection Timeout Expired> issue


#1

I encountered a problem when connecting to Server 1. The error message is “Connection Timeout Expired. The timeout period elapsed while attempting to consume the pre-login handshake acknowledgement. This could be because the pre-login handshake failed or the server was unable to respond back in time.”

I think the cause is in the server, because I can connect to server 2 which has similar environment to server 1 but Active Directory uninstalled. Does anyone know how to solve it? Thanks.

Client: Win 7 Pro SP1 64-bit / ToadSS 5.8.0.831
Server 1: Win Server 2003 SP2/ SQL Server 2000 / Active Directory installed.
Server 2: Win Server 2003 SP2/ SQL Server 2000


#2

Now I found that ToadSS 5.7.0.605 works well so I’ve downgraded to this version.
Connection failure occurs only in 5.8 (including beta). Hope this issue won’t take place in 5.9. >_<


#3

Hello,
Sorry for the silence. I’m afraid we do not fully understand the issue and therefore can’t reproduce it on our side. I’ve never confronted with such kind of issue and do not remember any complaints from the users…
Can you please describe a bit more the differences between these two servers? What do you mean by Active Directory installed/uninstalled?
Another supposition - can you reset TSS 5.8/6.0 settings to the default values to see if it can help?
Also - can you try to connect to Server 1 from any other machine from your network or outside?

Alexander

Message was edited by: Alexander.Maximov


#4

I’ve tried to connect to Server 1 from other machines on my network and the result is successful. I think the problem is in my machine. However, I can’t find the cause of the issue and don’t know why 5.7 works well but 5.8/6.0 doesn’t.

How to reset settings to the default values? I used Configuration Wizard and chose Default and then reconnect, but it doesn’t help.


#5

To reset settings to default values - close Toad instance and rename or delete this folder:
Vista/W7: c:\Users\AppData\Roaming\Quest Software\Toad for SQL Server 6.0
XP: C:\Documents and Settings\Application Data\Quest Software\Toad for SQL Server 6.0\

Start Toad and do not migrate settings from any previous version.

Please get back with results. In case of error - I need some more information about your environment,


#6

The result is still the same. Please tell me what kind of information do you need?


#7

You mentioned this difference between Server 1 and 2: Active Directory installed.
I’m afraid I don’t fully understand what does it mean.

BTW, please review TSS 5.8 Release Notes - starting from this release Toad started to loose support for SS 2000 in some areas. Sorry, but it it too old server version to fully support it.


#8

Active Directory is installed in Server 1, therefore I thought maybe I don’t have permission to access Server 1 because my PC isn’t joined AD. However, I found the cause of connection failure isn’t related to it after trying to connect to Server 1 using other machines; moreover, my PC can connect to Server 1 by using TSS 5.7.

I have noticed Release Notes already, but I don’t think it is the reason. As I mentioned previously, TSS 5.8/6.0 works well in other machines except for my PC.


#9

Hi vane,
Let’s try to see this from another side - what is Server name in Connection Properties dialog for the problem server?
Just so you know - it may be defined in different ways:
IP
IP,port
hostname
hostname\instancename


#10

The server name is WEBSERVER.

By the way, I get error message ‘ERROR [42000] [Microsoft][ODBC Microsoft Access Driver] Syntax error in INSERT INTO statement.’ when I run Automation. How to solve it? Exporting files in Access format works well except for using Automation.

Thank you.


#11

OK I see,
Did you have a chance to specify connect string in other formats like I noted above? In our environment we also having some problems to connect from non-domain computer to domain server. IP ofter helps. But IP,Port works all the time. Please try.

Regarding Error 42000 - can you please start separate topic so it can be easily tracked?


#12

It doesn’t work even if I use IP to connect to the server 1.
Connecting from my PC to server 1 using IP or Server Name works well Only in ToadSS 5.7. In later versions of ToadSS, all connection results of server 1 are failed. However, the result of using another machine which has the same OS with mine and every version of ToadSS is successful.


#13

Seems something definetely wrong with your PC settings/environment.
Actually I ran out of any other ideas… Don’t know why only TSS 5.7 works fine.

Also, did you have a chance to increase Connection timeout settings? (Tools\Options\Database\SQL Server\Timeouts)


#14

Yes, but it still doesn’t help. I also think the problem is on my PC. Nevertheless, I’m not planning to re-install OS at present. I’ll post the follow-up to this issue after re-installing OS in the future.


#15

Ok I see. Good luck!


#16

Risking being flamed here, but have you checked the obvious? The actual timeout settings in TOAD, under TOOLS->Options->Database->Timeouts


#17

As stated previously, I have checked the settings of Database - Timeouts, but it doesn’t work.


#18

Have you extended the timeouts to hours instead of minutes and see if that makes it? Check the timeouts in SQL Server directly:

http://technet.microsoft.com/en-us/library/ms189631.aspx


#19

I have also changed the timeouts settings of SQL Server and the result is the same.

There must be something wrong with my PC. Luckily ToadSS 5.7 works fine.


#20

I think I have found the reason. The differences among versions of Microsoft .NET Framework caused the problem. Toad works fine when Microsoft .NET Framework 4.0 is installed; however, if Microsoft .NET Framework is upgraded, connection issue occurs. :frowning: