Toad World® Forums

Connnection problem - SQL Server using Windows Authentication login

Hello -

This is my first post. I just downloaded the trial version of Toad Data Modeler in order to evaluate it. I already like it. However, I do have a problem:

When I try to connect to on of my databases with the sa password to reverse engineer it, I do not have a problem. However, when I try to connect to the database using my Windows ID/password combination, I get login denied.

I have tried logging in several ways:

 Domain\userid
 userid
 userid@xxxx.com

None work.

Any ideas?

Thank you.

Tammy

Hi,

I apologize for the delayed response. Are you able to connect to the database using different software product, e.g. Toad for SQL Server?

Regards,

Vaclav

I am sorry for not responding. I am now up and working with a paid copy of the tool.

Hi,

Thank you. Feel free to contact us in case you need our assistance.

Good luck,

Vaclav

Same problem here. I can create a SQL server user, and I can use it to connect to the server and the database, but if I try to use a Windows user for authentication, I get that same error:

Connection failed because of the folowing error: “Login failed for user ‘domainxyz\userabc’”

So, how do I get top connect using Windows Authentication? Since there is no problems connecting with a local SQL user id, all the links in the chain are working,except when using Windows authentication.

I am using the latest version, with Windows XP SP# and SQL Server 2005.

Ideas?

Thanks

Mike

Hi Mike,

what connection method did you use? There are two possibilities, Native Connection or ADO Connection.

If you had troubles with native connection, please try ADO.

Regards,

Vaclav

I was trying to use the native connection, since I simply wanted to use Windows Auth. instead of a SQL Server login account.

I have now been able to access using the ADO method.

But I feel it is at best a band-aid.

We should be able to use the native clients to use all the capabilities of the connection. I would like to understand why it only works with a SQL user, and not Windows Authentication. Is it by design, or is it a bug?

Inquiring minds would like to know…

Thanks

Mike

Hi,

we will look into the matter. Windows Auth was not supported but there seems to be a way to enable it. I created new change request: #102957.

Thanks for your feedback!

Vaclav

Hi Mike,

good news :slight_smile: The next BETA version will contain additional option for native connection and it will be possible to choose Auth mode.

Regards,

Vaclav

I also tried to use Windows Authentication to reverse engineer a database, I left the connection methos set to Native Connection and left the User name and password empty. I received an error message back station that the “sa” password was invalid.

When I switched to “Connect via ADO”, it asked me to enter the connection string. I entered both:

Data Source=myServerAddress;Initial Catalog=myDataBase;Integrated Security=SSPI;

and

Server=myServerAddress;Database=myDataBase;Trusted_Connection=True;

Replacing MyServerAddress and MyDataBase with real values, I also tried using the IP address for myServerAddress - nothing worked.

The only way I am able to connect is by using SQL Server Authentication - I have to create the account, reverse the database, then drop the account (we have strict security policies).

It would be much easier to select the connection method to use (Windows or SQL Server) and when using the ADO driver, prompt for the SQL Server and Database to connect to and TDM construct the connection string.

Update to my previous post on connecting to a database using ADO to reverse engineer a database. I used the “Data Link Property” and it created the connection string that works. I was able to connect using Windows Authentication this way, also if you save the connection string generate, you can reuse it by pasting it into the Connection String text box.

The connection string looks like this:

Provider=SQLNCLI10.1;Integrated Security=SSPI;Persist Security Info=False;User ID="";Initial Catalog=MyDatabase;Data Source=mySQLServer;Initial File Name="";Server SPN=myWindowsAccount

Hi Tom,

thanks for your feedback. The next BETA version will contain improved form for native connection. It will be possible to select SERVER or WINDOWS authentication and fill out the necessary values like user and password. See screenshot.

Regards,

Vaclav