Toad World® Forums

Copy from Editor with RTF removes chars after tabs

Howdy,

Subject about says it all – in .40, I copy SQL from the Editor with the “Copy text in rich text format” option enabled, but the paste removes the tabs and the word immediately following each tab.

Workaround is to not use the RTF option, but she ain’t as purdy.

TIA!
Rich

Are you using Tab character instead of spaces! If so, send me an example and what app are you pasting into? I don’t have MS product here to paste into, but using tab char and pasting into LibreOffice is working ok. I can try paste into Outlook/Word at home,
however. My example is super simple.

select *

\tfrom dual;

On 02/05/2015 05:02 PM, Rich J. wrote:

Copy from Editor with RTF removes chars after tabs

Thread created by Rich J.
Howdy,

Subject about says it all – in .40, I copy SQL from the Editor with the “Copy text in rich text format” option enabled, but the paste removes the tabs and the word immediately following each tab.

Workaround is to not use the RTF option, but she ain’t as purdy.

TIA!

Rich

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - Beta
notifications altogether.

Toad for Oracle - Beta Discussion Forum

Flag
this post as spam/abuse.

Hey Michael!

Weirdness, but it works now in .42. I thought I may have accidentally fixed it because I had earlier noticed that some evil person switched my “Tab mode:” to “Spaces” (EEEEVIL, I tells ya!), but no matter which way I toggle that, copy and pasting with RTF now works fine.

So you get full credit. Thanks, Michael!

Rich

Well that’s good. I can’t think of anything off hand that has been changed to fix it so let me know if it creeps up again.

On 02/13/2015 04:32 PM, Rich J. wrote:

RE: Copy from Editor with RTF removes chars after tabs

Reply by Rich J.
Hey Michael!

Weirdness, but it works now in .42. I thought I may have accidentally fixed it because I had earlier noticed that some evil person switched my “Tab mode:” to “Spaces” (EEEEVIL, I tells ya!), but no matter which way I toggle that, copy and pasting with RTF
now works fine.

So you get full credit. Thanks, Michael!

Rich

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - Beta
notifications altogether.

Toad for Oracle - Beta Discussion Forum

Flag
this post as spam/abuse.

Triple weirdness – looks like this might be back, at least in .67 and .68. With this in my Editor:

SELECT
‘GO’,
‘BADGERS!’
FROM DUAL;

DELETE FROM mytable1
WHERE NOT EXISTS
(
SELECT 1
FROM mytable2
WHERE
col1column = col2column
);

…it pastes into Word as:

SELECT
‘GO’,
‘BADGERS!’
FROM DUAL;

DELETE FROM mytable1
WHERE NOT EXISTS
(
SELECT 1
FROM mytable2
WHERE
column = col2column
);

The indentations are really TABs. The SELECT retains its tabs, while the WHERE clause does not (’[CHR9]col1column’ gets truncated to ‘column’).

Thoughts?

TIA!
Rich

I have no idea, but I’ll give it some deep thought over a Boddington’s.

I’ll take a look tomorrow.

On Apr 6, 2015, at 5:28 PM, Rich J. bounce-rjesse@toadworld.com wrote:

RE: Copy from Editor with RTF removes chars after tabs

Reply by Rich J.
Triple weirdness – looks like this might be back, at least in .67 and .68. With this in my Editor:

SELECT

'GO',

'BADGERS!'

FROM DUAL;

DELETE FROM mytable1

WHERE NOT EXISTS

(

SELECT 1

FROM mytable2

WHERE

col1column = col2column

);

…it pastes into Word as:

SELECT

'GO',

'BADGERS!'

FROM DUAL;

DELETE FROM mytable1

WHERE NOT EXISTS

(

SELECT 1

FROM mytable2

WHERE

column = col2column

);

The indentations are really TABs. The SELECT retains its tabs, while the WHERE clause does not (’[CHR9]col1column’ gets truncated to ‘column’).

Thoughts?

TIA!

Rich

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - Beta
notifications altogether.

Toad for Oracle - Beta Discussion Forum

Flag
this post as spam/abuse.

This is fixed for next beta.

Boddingtons FTW!

Rich

Fixed for next beta.

From: Rich J. [mailto:bounce-rjesse@toadworld.com]

Sent: Monday, April 06, 2015 5:28 PM

To: toadoraclebeta@toadworld.com

Subject: RE: [Toad for Oracle - Beta Discussion Forum] Copy from Editor with RTF removes chars after tabs

RE: Copy from Editor with RTF removes chars after tabs

Reply by Rich J.

Triple weirdness – looks like this might be back, at least in .67 and .68. With this in my Editor:

SELECT

'GO',

'BADGERS!'

FROM DUAL;

DELETE FROM mytable1

WHERE NOT EXISTS

(

SELECT 1

FROM mytable2

WHERE

col1column = col2column

);

…it pastes into Word as:

SELECT

'GO',

'BADGERS!'

FROM DUAL;

DELETE FROM mytable1

WHERE NOT EXISTS

(

SELECT 1

FROM mytable2

WHERE

column = col2column

);

The indentations are really TABs. The SELECT retains its tabs, while the WHERE clause does not (’[CHR9]col1column’ gets truncated to ‘column’).

Thoughts?

TIA!

Rich

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - Beta
notifications altogether.

Toad for Oracle - Beta Discussion Forum

Flag
this post as spam/abuse.

Ignore the duplicate post. When the ToadWorld mail server is working it’s often horrifically slow. That message took ~40 mins to deliver.

Following up on this thread, I confirmed this is now fixed in .73 and .76.

Thanks much, Michael!

Rich

Thank you for confirming the fix. This is very helpful for us in QA

From: Rich J. [mailto:bounce-rjesse@toadworld.com]

Sent: Thursday, April 16, 2015 9:55 AM

To: toadoraclebeta@toadworld.com

Subject: RE: [Toad for Oracle - Beta Discussion Forum] Copy from Editor with RTF removes chars after tabs

RE: Copy from Editor with RTF removes chars after tabs

Reply by Rich J.

Following up on this thread, I confirmed this is now fixed in .73 and .76.

Thanks much, Michael!

Rich

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - Beta
notifications altogether.

Toad for Oracle - Beta Discussion Forum

Flag
this post as spam/abuse.