Toad World® Forums

TOAD 12.10.0.30: Copy/Paste from TOAD to Microsoft Word runs not properly!

Hello,

Although I checked “Copy text in rich text format” in Editor/Behaviour

Copy/Paste from TOAD to Microsoft Word runs not properly!

Original text in TOAD editor: select * from mytable; – C’est une table composée de lignes fermées.

Paste into Word display: select * from mytable; – C’est une table compose de lignes fermes.

As you can see the é are lost!

Someone could confirm this disfunction ?

My Operating system is: Microsoft Windows 7.

Thanks.

Hi!

I have a support case with Quest regardiung this and they hace confirmed it’s a bug.

Best regards

/Rickard

Hi Rickard!

If you are interested, i have found a workaround:

. Select and copy text from TOAD into clipboard.

. Open Notepad++, change the language to SQL and paste the select text from clipboard.

. Select the text

. Copy the select text into clipboard with the plugins NppExport: Plugins>NppExport/Copy RTF to clipboard

. Paste the selected text from clipbaord into a Word document.

Best regards, Antonio.


Hi,

Do not follow that.

It seems to be a Toad bug and in Notepad, paste is working from Toad!??
Is UTF-8 default encoding in Notepad?
What is default encoding in Word?

What am I missing here?
Brg
Damir

This is a Toad bug and it’s logged. I haven’t spent any time on it yet. It’s not a straight encoding problem in the traditional sense. Toad can handle those chars just fine, but it’s encoding them incorrectly when formulating the RTF document. The logic Toad is using is to take the char as-is when it is 1-byte and convert use the RTF Unicode representation for chars exceeding 1-byte. This is apparently incorrect for chars having diacritical marks.

To have your code retained without corruption disable Copy in Rich Text Format option. You can copy/paste into Word without problem. You lose syntax decoration effects, but your code formatting and chars are unchanged. You may need to manually set your Word font to fixed width for your pasted code, but that’s it.

Michael

Michael,
perfectly clear now.
Thx.
Damir

Hi,

The reason why i use Notepad++, is to keep the colors of the SQL syntax for documentation purpose!

No need to uncheck “Copy text in rich text format” in TOAD.

Antonio.

This is fixed for 12.11.