Toad World® Forums

Decimal places error when exporting to Excel

Hello

I have a really big problem with exporting numerical values to Excel. All values in Excel are multiplied by 100 and without decimal places.

So if the original value from DB was 604,95 then the exported value is 60495,00.This makes TOAD totally unusable.

This problem seemed to start with Toad version 6.1; before export from same tables worked without problems.

Toad version: 6.1.0.17.59

OS:Windows 7; Enterprise 64 bit; service pack 1

Office: Professional Plus 2010

Language: Slovenian

Please Help

BR

Hi,

I can’t reproduce this issue.

case1:

I use datas type as numeric(18,0). Then I export the data with standard format. it display without decimal places in excel. I think this is correct.

case2:

I use datas type as numeric(18,2). Then I export the data with standard format. it show 2 decimal places in excel. This is correct.

case3:

I use datas type as numeric(18,0). Then I export the data with Number(N) format. it show 2 decimal places in excel . This is correct.

Am I miss something? I test it in 6.1.0.1759. Could you provide more detail? like the export data and reproduce vedio? Please feel free to contact me.

Email: kelly.chen@quest.com

Best Regards,

Kelly

Hello,

suddenly I have the same problem. I have not changed any settings, wether in Toad nor in Excel 2010. In the Toad Results the numeric data is shown correctly (comma as decimal seperator), but when I export it to Excel as Excel file, CSV file or HTML file, all commas are changed by points.

For example: Toad Result = 5,000000 --> file output = 5.000000,00

If I use the Excel Instance Export all data is transfered correctly, commas persist as commas in the opening Excel file.

I am using the Toad export function for years, but this problem is new and really strange.

I would be very grateful if somebody could help me.

Toad version: 6.5.0.3001

Options -> Environment -> Grid -> Data Type Formatting -> Number -> Standard()

OS:Windows 8.1; Enterprise 64 bit

Office: Standard 2010

Language: German

Hi,

I have receive your Email with the Screen shot. Thank you very much. I met this situation after I change my language as German.
But we don't think this is an issue. The data format in excel is base on the system language. Like attachment.
The Toad options will not effect the export format for now. The option only support the data format display in toad data grid.
So we can set the sys format. Thanks again!

Best Regards,

Kelly

Hello Kelly,

thank you for your reply. I have the same settings like you in your screenshot.

I talked to a collegue who has the Toad version 5.7.0.605 running. He has not this problem, Quick export to Excel works fine. He has the same Windows settings and Toad/Grid settings like I have in my Version 6.5.0.3001. Could it be a little bug in the new version? I upgraded to 6.5. a few weeks ago. Maybe I haven’t noticed the problem in the meantime. Another collegue with version 6.5. running has the same problem now…

Thank you an best regards

Josh

Hi,

I'm so sorry for confuse you. The screen shot I attached last time means that promblem is because the sys em setting but not means it's the right setting.

I try the Toad for SQL Server 5.7, with Decimal symbol as ',' and Digit grouping symbol as '.'

It also has this problem.

So please set Decimal symbol as '.' and Digit grouping symbol as ','. Try to setting like attachment this time. Hope this can help you solve this problem for now. Thank you very much!

Hello Kelly,

I changed the Windows settings and concerning the Toad Export it solves the problem. But logically this settings effect the entire system and all other programms. That is not a satisfactory solution, because in Germany the decimal seperator is comma and we are all used to work this way.

I think there is another problem. My collegue with version 5.7 running has the same windows 8 settings as the ones with version 6.5 running and the export function of both versions work different. Moreover, if I use version 6.5 with the windows 8 "german" settings the****other export function "Excel Instance Export" delivers the right results, commas persist as commas in the opening Excel file. Why do they work in different ways? That's really strange, particularly because in version 5.7 they do work similar on our systems.

Following you can see the difference between the two export functions in version 6.5:

If we can not fix this problem I think I will only use the Export Instance function. The disadvantage with this method is that the cells are formatted automatically by Excel as you see in the screenshot. That causes some other little problems... :frowning:

BR

Josh

Hi Josh,

Thank you very much!

Sorry for your inconvenience now. The Grid Options local-independent format still have problem. We have TSS-807 for this. And after this issue been fixed, we can use the format independent by OS.

For the incorrect data toad export. I reproduce in German format. Yes, you are right, this problem is show up since 6.1. And this is OK in 5.7. Thank you very much. I create TSS-823 for this problem.

I will keep you update about this two task. Thank you again.

Best Regards,

Kelly