Toad World® Forums

disable prefix for schema name

Hello,

I’m using trial version of Toad for Sql Server ver. 6.6.0.963. What I want is to disable the insertion of “dbo.objectname” when auto complete suggests things.

I’ve already disabled the Editor - Code completion --> Insert default schema name checkbox, but Toad still gives me the suggestions with the .dbo prefix, and for me it’s redundant (call me puristic).

Thanks in advance !

Hi,

I try 6.6.0.963, but I can’t reproduce this problem. Could you please kindly check the setting in file?

Help->about-> click Application Data Direcotory

In ModuleSettings -> Insight.xml

Please see if the insertDefaultSchema still as true.

If yes, please try to edit the xml file and remove the line.

If no, and you still have this problem. please provide the script you can reproduce the problem. Thank you in advance.

Best Regards,

Kelly

Hello Kelly,

I have checked the settings in insight.xml and the option is not there. Also, the option in the tools/options/editor/code completion/general/ “insert default schema name” is not checked.

What I’ve found is that it only happens when I 'm selecting with joins

i.e.

“select * from clients where …” does not write the prefix (dbo.) -> OK

but

“select * from clients join policy on policy.cli_id = client.id …” always writes the prefix (dbo.) even if I delete the “dbo.” prefix inserted before the name tables.

Thanks again !