Toad World® Forums

Editor - change in behaviour with shift + home

Hi,

I just noticed that there’s now a change in behaviour when hitting shft + home - in 12.6, if you’re on a blank space between the start of the line and the first letter and you hit shift+home, it highlights the spaces between the caret and the start of the line. This is consistent with Microsoft Word and Notepad. In 12.7, however, it highlights the spaces between the caret and the first letter (mimicking what ctrl+shft+right arrow does).

I know this is a small thing overall, but I do a lot of reformatting by clicking on a space and hitting shift+home; is there any chance of switching the behaviour back to the 12.6 way? Thanks!

toad_ctrl_home.jpeg

Bumping, just in case the email got lost in the aether… at least, I hope that’s what happened, and it’s not that I’m persona non grata! *{;-D

Fixed for next beta. To get the fix may need to modify your key mapping a little. If you have the file EditorShortcuts.xml in your User Files then do the following. In Options on the Toolbars/Menus|Shortcuts page select each of the following commands and click
“Reset current.” Home, Home select, Home block select, VC Home, VC Home select, and VC Home block select. If you’re missing that file you should be good to go without modification.

Thanks,

Michael

On 03/09/2015 10:42 AM, Boneist wrote:

RE: Editor - change in behaviour with shift + home

Reply by Boneist
Bumping, just in case the email got lost in the aether… at least, I hope that’s what happened, and it’s not that I’m persona non grata! *{;-D

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - Beta
notifications altogether.

Toad for Oracle - Beta Discussion Forum

Flag
this post as spam/abuse.

Boneist, there’s still going to be a difference from 12.6 in the next beta. I’ll have it completely fixed for .52.

Thanks,

Michael

On 03/09/2015 12:01 PM, Michael Staszewski wrote:

Re: Editor - change in behaviour with shift + home

Reply by Michael Staszewski
Fixed for next beta. To get the fix may need to modify your key mapping a little. If you have the file EditorShortcuts.xml in your User Files then do the following. In Options on the Toolbars/Menus|Shortcuts page select each of the following commands and
click “Reset current.” Home, Home select, Home block select, VC Home, VC Home select, and VC Home block select. If you’re missing that file you should be good to go without modification.

Thanks,

Michael

On 03/09/2015 10:42 AM, Boneist wrote:

RE: Editor - change in behaviour with shift + home

Reply by Boneist
Bumping, just in case the email got lost in the aether… at least, I hope that’s what happened, and it’s not that I’m persona non grata! *{;-D

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - Beta
notifications altogether.

Toad for Oracle - Beta Discussion Forum

Flag
this post as spam/abuse.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - Beta
notifications altogether.

Toad for Oracle - Beta Discussion Forum

Flag
this post as spam/abuse.

Ok, thanks; I’ll wait until then to double-check it.

I was able to sneak it into today’s beta (.51).

On 03/09/2015 01:21 PM, Boneist wrote:

RE: Editor - change in behaviour with shift + home

Reply by Boneist
Ok, thanks; I’ll wait until then to double-check it.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - Beta
notifications altogether.

Toad for Oracle - Beta Discussion Forum

Flag
this post as spam/abuse.

Thanks again, Michael - I can confirm it’s now working ok.