Toad World® Forums

Enhancement request - Paste block in editor


(right-click) -> Edit -> Selection mode -> Block is a really cool feature. But i couldn’t find a way to paste the copied block so that no new lines are generated. Tried with Overwrite on and off (Insert) and pasting with block selected where to paste - no matter what the first row gets pasted ok but for the others new lines are inserted.
I don’t know whether it’s better to change the behaviour of Paste when in Block mode and dependent on Insert/Owerwrite mode or add an new Paste option (“Paste block” or “Paste overwrite” for example)). This would make the feature even more useful.



Hi Andres,

It works ok for me. Could you please post some sample script and a screenshot of what you get after pasting?



Hello, sorry for late reply.
ok i experimented some more and here are my results - if you copy and paste via menu, or right-click, the paste works as if in stream mode. If you copy and paste via Ctrl+Insert and Shift+Insert it will work as expected. And - once it has worked once, you can copy and paste whichever way you like, it will continue working correctly until you close and restart SQL Navigator. So to try this, you should start with a fresh instance of SQL Navigator.


Hi Andres,

I can reproduce it now. A CR has been raised for this bug. Thanks for your feedbacks.