Toad World® Forums

Entity Properties/Attributes grid behaviour


#1

Hello,

I just noticed a behaviour in the Entity Properties/Attribute that I haven’t noticed before. It is minor but it is kind of annoying. I am using TDM 6.4.4.42.

Here are the steps to reproduce it.

  • Double-click on an entity with lots of fields, enough to make the vertical scrollbar appear in the Attributes grid.
  • Scroll to the bottom and double-click, let’s say, on the 5th attribute counting bottom-up.
  • Select a domain for the attribute. Behind the Attribute Properties dialog, in the attributes grid, the selected attribute is scrolled in the grid to the bottom as soon as I select the domain. It is annoying because I have to scroll up when I move to the next field. I usually add the fields first and then I modify their types and other attributes one by one.
    Is there anything that you can do to leave the field where it is in the grid when the domain changes?

Thanks


#2

Hello Costa,

It looks like you enabled the sorting of the attributes by the data type by click on the header of the column Data type in the Attribute grid. You can turn if off by the click on the first (unnamed) column in the Attribute grid on the Entity properties.

sortingdt.jpeg

Regards

Dave


#3

Hi, Dave,

Thank you for the reply. The grid was not sorted by the Data Type column, it was sorted by the column position (i.e. as you said, by the first unnamed column).


#4

Hi Costa,

I’ve tried your procedure again and I know what you mean yet. This behaviour is as design but I can understand it could be annoying for your workflow. I will create an enhancement issue, but I am afraid the priority will not be high. As workaround you can use the navigation combo box in the header the attribute properties to switch to another one or change the data type in the attribute grid.

Regards

Dave