Toad World® Forums

ER Diagram seems to Cache its information

If I create some tables and then create an ER diagram of them, it does it exactly as I would expect. If I then make some changes to those tables and go back, the ER diagram does not show the updates.

E.g. 1. Create 2 tables and join them with primary/foreign key.

  1. Go to schema browser

  2. Select 2 the tables and create ER diagram

  3. go back and add some extra columns

  4. go back to schema browser and refresh (confirm that new columns are there)

  5. create new ER diagram - new columns are not there.

If I start a new connection and go to the schema browser and create the diagram, the new columns appear.

Is this intended functionality, a bug, a setting or am I just doing something wrong?!

Thanks in advance,

Mark.

Hi Mark,

Which version of Toad are you using? I just tried the steps you outlined in Toad 12.12 and the current beta, and the new columns appear when creating a new ER diagram on step 6 for me. Are you using an older version of Toad?

-John

Hi John,

I’m using 13.0.0.30 but I also tried it on the 12.12 production version on a different PC and got the same results both times.

Thanks,

Mark.

Hi Mark,

Can you post some screenshots or provide more information about this issue? For me, on both the current beta and Toad 12.12, the additional columns are appearing when creating a new ER diagram after following your steps.

-John

I just created this example in Toad 13.0.0.30

Create Table MG_TEST_1

(

Col_1A Number Not Null Primary Key

);

Create Table MG_TEST_2

(

Col_2A Number

);

Alter Table MG_TEST_2 Add (

Constraint MG_T2_FK

Foreign Key (Col_2A)

References MG_TEST_1 (Col_1A)

Enable Novalidate);

– Go to Schema Browser and highlight the 2 tables

– Right-Click --> ER Diagram (Fig. 1)

– Dialog appears: Please Wait…Updating Diagram (Fig. 2)

– ER Diagram is created (Fig. 3)

– Close ER Diagram and continue here

Alter Table MG_TEST_1

Add ( Col_1B Varchar2(30) );

Alter Table MG_TEST_2

Add ( Col_2B Date );

– Go back to the Schema Browser and click the “Refresh All Objects” icon. (Fig. 4)

– Look at the 2 tables to show that the added columns are there (Fig. 5 and Fig. 6)

– Highlight the 2 tables

– Right-Click --> ER Diagram

– This time there is no dialog

– ER Diagram (Fig. 7) is the same as in Fig. 3.

[View:/cfs-file/__key/communityserver-discussions-components-files/86/ER_5F00_Diagram_5F00_Screenshots.docx:320:240]

Thanks,

Mark.

Forgot to add:

– Create a new connection and go to the schema browser

– Highlight the 2 tables

– Right-Click --> ER Diagram

– New ER Diagram created with new columns included (Fig. 8)

[View:/cfs-file/__key/communityserver-discussions-components-files/86/ER_5F00_Diagram_5F00_Screenshots_5F00_2.docx:320:240]

Thanks,

Mark.

Update: I have tried this again in 13.0.0.43 and it still happens.