Toad World® Forums

error loading libpq.dll

Dear All,

I’m having this error message trying to RI a postgresql database.
I know everything about libpq.dll and all the other dlls required to connect to postgresql; in fact I’ve copied them in BIN folder; no luck.
I’ve tried to copy files in windows\system32, again no luck…

I have also the beta installed; I’ve tried to copy these dlls in beta BIN folder also,
and BETA does work!!!

I strongly preferred (and also understand… hey, it’s a beta!) to have current release working and beta not, but the contrary…!!! (beta expires, current release not; also I can open a RI file with beta, but the contrary is stated is not possible…)

Any idea???

Hi Roberto,

the Beta works because a new Native Connection component was added, which fixes former issues with 64-bit PostgreSQL libraries (now you don’t have to have the libraries copied in Toad Data Modeler Bin folder at all) and you probably have them, don’t you? To be able to connect properly, you would need to copy 32-bit libraries.

Anyway, though this beta version may expire, there is always a new beta release available before the old beta expires. And if you RE a database with the current beta, you will be able to open the reversed data model in the next full release of Toad Data Modeler. The said compatibility restrictions are meant for older full releases, for the reason that older full releases may not be compatible with the newer beta release in terms that if there was some change made to any of the components used in RE and a generated data model includes these changes, then the older full release won’t be able to open the model.

Regards,
Lukas

Message was edited by: Lukas