Toad World® Forums

Error "Object reference not set to an instance of an object."

Hi All

when i run an automate script, i get above error message

help thank you
juman

I would need more info about what is in your script. Can you copy and paste the output lines that show the steps in the automation script?

P.S. I ran into this issue yesterday when I was running a Toad Data Report and I had it with the wrong type of connection. I have since fixed this issue but it is not in the released code. This may or may not be your issue.

Hey Debbie,

The automate script is a combination of:-

  1. a sql script to be exeucted
  2. select file which is a spread sheet file where is output

please see attached screen shot of automate script file and settings

i hope this will help

thank you

Unfortunately this does not give me enough info.

Can you do the following?

  1. Double click on the connection (yellow area) and confirm that the script is using the correct connection.
  2. Double click on the script settings(Top grey box). Scroll to the bottom and change the logging level to ‘Verbose’.
  3. Run the script to produce the error and send the log file to my email address: dpeabody@quest.com

If the log file is using the default path you can easily find it by opening up the About Box, select ‘Application Data Directory’ and go to the Automation directory. The *.log file will have the same name as your automation script.

Thanks debbie

I am having the same issue in TDP 3.4, I attached the log file. It is failing on the import component. If I execute the import (Tools/Import/Execute) it runs fine but the automation job step calling that import fails. I tried to attach the .tas and .tim files but only seems to allow me to attach one.
TES.log (4.78 KB)

Here is another attachment.
TES.tas (11.6 KB)

Here is the last attachement but it would not let me attach it as a .tim file so I renamed it to .txt
Load Stage TES_Encounters.txt (1.49 KB)

I tried breaking up the import (from extracting from one connection into another connection) to Extracting to a file in one step and then importing from that file in the next step and I did not get the error. So the problem seems to be with the import query connection. When I run it manually I do get a warning message that I have to click OK to. I think that was fixed in 3.4 automation but maybe only for the connection that you are importing into and not the one that you are connecting to for running the query.

Sorry for not respondidng promptly.

We’ve fixed a couple of bugs lately in this area exactly (importing in Automation). Please check the latest beta that I’ll be posting soon to see if your issue is resolved.

Thanks,

Igor.

Hello Greg,

Did you have a chance to check if the problem persists in the latest 2831 beta?

Thanks,

Igor.