Toad World® Forums

Execute SQL via SQL*Plus is greyed out in Toad for Oracle

I have Toad for Oracle Xpert (64-bit) version 13.3.0.181 running on Windows 10 Enterprise. I have Auto detect paths enabled in the options window. I would like to run a script in the SQL Plus window, but it is not available.

image

Hi Robert,

Check to make sure you have an active connection assigned to your editor tab before trying to execute the statement. You might need to re-select an existing connection to make sure it's assigned. You can check to see if you have an active connection set for the tab with the following connection button:

image

Feel free to let us know if that doesn't solve the issue you're seeing.

Thanks,

-John

Yes, I am connected to the database. Maybe I needed to run Toad as administrator. I did that just now and it is letting me push the button.

It lets me push it, but nothing happens when I do. Shouldn't it open a little SQL Plus window?

If you opened the Editor before making a connection to the database, click the button that John Bowman indicated to attach the Editor to your connection. Judging by your screenshot in your first post, it looks like one of 2 things is true: Either there is no SQL text in your editor, or your Editor is not tied to a connection.

If you make the database connection before opening the Editor, it is attached to the connection automatically.

I think there is a misunderstanding somewhere. I can connect to the database and run queries just fine. I have a script that takes an hour to run. Toad locks up and I cannot do anything while a query is running. So I would like to run my script in the background. I used to do this with nohup on a Linux server, but I no longer work with Linux servers. I only have Toad for Oracle now. I see there is a button called Execute via SQL*Plus. I assume it serves the same purpose, but it does nothing when I press it.

Well in your original screen shot, there was a lot more disabled besides just Run in SQL Plus, hence the reply from the other John and me

After you check that box, when you Click OK, Toad should look for sqlplus, etc. If you go back in there, are those paths filled in now?

If so, make a connection, put a script in the editor and try again. If it’s still disabled can we get another screen shot of the whole editor? If it still does t work, I’m missing something something but not sure what.

I apologize about that. I admit I am bad at explaining things.

I have the box checked.
image

The menu item and toolbar button are now clickable, but nothing happens when I click them.

image

I was expecting to see the full path to those programs in all of those boxes. That may be the problem.

For now, Try hitting the ... button in the options window and manually find sqlplus.exe.

I can take a look tomorrow when I’m back at work and see if I can figures out what’s going on.

Does your Oracle client include sqlplus? If it's an instant client, it may not.

I can reproduce the problem of the button doing nothing if I connect using an instant client which does not include sqlplus.exe.

Go into the options window and try the "Auto Find" button. If it's installed, that should find it. If it's not installed, go here and scroll down to the Oracle clients. Be sure that the Oracle client bitness (32/64) matches that of Toad. https://www.oracle.com/database/technologies/oracle19c-windows-downloads.html

I appreciate your help. Is there a specific location I need to install it?

image

It looks like you are about to install the full database. You only need to install the client.

Scroll down on the page I gave before until you see " Oracle Database 19c Client (19.3) for Microsoft Windows x64 (64-bit)" That's what you want (assuming you have 64 bit Toad).

There are 2 client options there. I find the "Client" one easier to install than the "Client_home" one.

Once you download it, the installation folder does not matter.

Thank you. I am downloading it now. Do you think I'll need to change any paths or environment variables to install?

It will update your path automatically when you install it. You may need to set up a TNSAdmin environment variable if you haven't done that already.

SUCCESS! Thank you sir.

Awesome! I'm adding a "SQL*Plus could not be located" type message so it's a little easier for the next person who hits this. :slight_smile: