Execute editor window as a script doesn't work

I'm using Toad for Oracle Base Edition.

When I try to run the commands in my Editor window as a script by clicking on Execute Script (F5), nothing happens. Nothing appears in the script output window, no values are requested for "variables" and even though the statements may be creating objects, these are not created. It's as though Toad is doing nothing!

If instead I run using the "Execute via Sqlplus" option, a sqlplus window opens and the script runs as expected.

Why isn't this script functionality working?

Is the toolbutton enabled or disabled? If disabled, the rules for enabling the execute script feature are as follows...

  • Text is in Editor
  • Connection is established
  • Connection is read-write
  • Editor text is not for an object that is controlled by Team Coding
  • The PL/SQL debugger is not active
  • There is not a query already running via Execute Current Statement (F9)
  • The Data Grid tab for the active Editor tab is not fetching all records

Do any of those items apply to you that would be disabling it? Check that you do not have your connection set to read-only and that Team Coding is not in use or if it is, is the Editor text PL/SQL DDL for a controlled object? Did you start the PL/SQL debugger in that Editor instance and is it in a "stepping" state or stopped at a breakpoint?

I can confirm that none of those items are disabling it.

I'm not using PL/SQL debugger. I have an editor window with 3 simple statements to drop a view, create the view and grant access to the view. I can run each statement individually without issue using "Execute/compile statement (F9)" but running as a script does not run any statements. The Script Output scrolls up/down, but nothing is displayed within it.

After attempting to run the script I see the window bar message shows:

45068 days 15:59:03 hours

No idea what this means and I've never noticed it before. By which I mean when using Toad at other client sites. Normally, this displays the execution time of the statement.

On the General page in Toad's Options check the "Enable logging" checkbox. You will be prompted to restart Toad. Allow Toad to restart and try to run your script. Close Toad and locate the log files folder within your application data directory. Its default location is %APPDATA%\Quest Software\Toad for Oracle\16.3\Logs. You can confirm its location on the Files and Folders|App Folders page in Toad's options. Please email all log files in that folder to michael.staszewski@quest.com.


Thanks Michael, I'll attempt to get this to you first thing in the morning.

1 Like

@mstaszew I have emailed the requested log files to you.

Just to give an update, it seems this issue was being caused by some Windows Exploit Protection settings being disabled. My client had disabled some settings for additional security and when they were turned back on then Toad worked without issue.
Despite excellent help from Quest Support, it wasn't possible for my client to identify exactly which EP settings needed to be enabled to allow Toad to run without issue, but fortunately for me, my client has allowed all the EP settings to be set so that they don't cause this issue with the script engine in Toad.