Toad World® Forums

Export / Import on New Connection screen fails to restore passwords

Good Afternoon TOAD Team,

I work in two domains, dev and production, and like to keep my TOAD in each with the same settings.

I expect passwords to be lost when I import TOAD configuration from production into development, so before import settings, I test my connections in development and export my dev connections (Export on the New Connection window). Then import settings. Then I import connections from the file that I just saved, the connection order is restored, but not the passwords, even if I restart TOAD after connection import. Please fix.

In production I have limited rights and TOAD is 13.0; in development I have admin rights and TOAD is 13.2.0.146 and earlier, too.   I tried the same procedure above, except the target TOAD was 13.0, like the source TOAD version, as expected, passwords lost, but on restore only my read-only accounts lost their passwords, other password were retained.  TOAD 13.0 does not offer password encryption like 13.2 does, and I chose to encrypt my password export with this password, it is a physical password, all keys next to each other on a standard QWERTY keyboard: `1q2w3E$R%t6y7u8

Larry

Hello Larry,

Let me see if I understand the steps to the issue correctly...

  • You're using Toad 13.2* to export your connections with passwords from the login dialog.
  • You're importing settings from an older Toad 13.0* to Toad 13.2*.
  • You're using Toad 13.2* to import your connections with passwords to the login dialog.

Are those the correct steps?

Good Afternoon Mike,

Yes, sir! That is correct.

BTW, I do not understand how my side thought on background was made hard to read in the post; it all started as this attached word file (slight
post posting edits).

Larry Wickliffe

Monitoring, Performance and Tuning Services Lead, Data and Business Intelligence Services (DABIS)

Office of Information Systems and Technology

Employment and Training Administration

U.S. Department of Labor

202-693-3485 Office - forwarded to cell

Wickliffe.Larry@dol.gov

Telework Day: Thursday

(Attachment passwords to be lost when I import TOAD configuration .docx is missing)

The import logic in the login window is such that it won't override any existing connections that have the same user and server.

Is it possible that when you're importing settings from Toad 13.0* the connections are already in there (without passwords of course)? Then when you're importing the Toad 13.2* connections they're not sticking because it's finding the Toad 13.0* connections.

You could verify that by finding a connection you know is in both your 13.0* import and 13.2* export and deleting it from the login window (after 13.0* import) then importing 13.2* connections and seeing if the deleted connection and password import successfully.

PS, I believe you tried to attach a docx file but it didn't come through.

Good Morning Mike and TOAD team,

I deleted a couple accounts before another import and this workaround does succeed. The passwords for the deleted accounts are restored. I'd recommend modifying the logic to allow overwrite; what is the point of import if it will not overwrite what is there?

Larry

Hi Larry,

The merge logic for connections has been in there for many years and could probably use a little love. I'll make a note to take a look at this.

Mike