Toad World® Forums

Importing session passwords

I've installed a new version of Toad 13.2 on a machine that I'm migrating to. I've exported the sessions with passwords on the other machine(also 13.2), and imported those into the new instance. There are no passwords when I open the new instance. I've also tried copying the connections.xml file over, and the passwords get blanked out once I've opened Toad. What am I missing?

New with 13.2 make sure you're exporting the connections with their passwords.
image
As well as importing the connections with the passwords using the same password that was used during export.
image

Hope that helps. If there's still an issue let us know.

Mike

Yep, I did that. It's like there's a flag somewhere that says "Clear existing passwords on initialization." I was able to type a password for one connection, and it "stuck". Is there a dialogue box telling you when the import/export is finished? I never got one, but I didn't wait a long time.

There's no confirmation but they should import into the login window automatically with the passwords. Just to make sure - Is Save passwords checked?
image

Yes, it is. I copied over my user settings, and I'm wondering if I should remove the connections.xml file before I try importing.

So, that worked. I renamed my connections.xml to something else, and then did the import.

1 Like

Perfect - I was just typing similar. The import won't overwrite connections that already exist (in this case it sounds like they were in there but without passwords). This behavior could be made more clear.