Toad World® Forums

Formatted XML - lines too long for ClearCase


#1

Hi,

After making some changes I could not check my model (txp) back into ClearCase.

After some investigation this was because of the line that was 108,000+ characters long.

Narrowed it down to;

After making the changes and saving the model the XML is OK.

Generating a change script causes the Save icon to become active.

Clicking on this to save the model results in a new section being added into .

contains

which contains the long lines.

Can the format of this be controlled?

TDM 5.3.4.13

Oracle 11gR2

Windows XP 32 bit SP3


#2

Hello there,

Everything under is information about the last Model Action (Convert, Change Script generation, Merge) that has been used on the Model. This feature was implemented in 5.3. When you open the Model Actions window in your Model with huge number of lines (Model Menu | Manage Model Actions), you will see one or more stored Actions called last Action. As you may guess, they repeat the last Model Action without you needing to configure anything again. They are primarily meant to save time.

In your case though, you might want to delete them to save space and to greatly reduce the number of lines in your .txp file. Either delete the entire section in file or just delete all last****Actions in the Model Actions window.

We now consider implementing an option to disable automatic last Actions saving in the future version of TDM.

Regards,

Lukas


#3

Thanks Lukas.

It does seem a useful feature.

Maybe you could consider limiting the line length in saved actions when the formatted XML setting is chosen.

Malcolm