Toad World® Forums

Toad Data Model 6.5 is slow


#1

Hello,

Toad data modeler is not responding well today, whenever I save my work its taking more time to save, finally it forced me to kill the session. Is TDM is under maintenance ?

Thanks !!
Rajesh


#2

Hello Raaj,
could you specify database version of your model and describe type and counts of objects that you have in your model(Entitis - 500, Attribues-5000 etc.)?
Do you have 6.5.4 or 6.5.5 version?
Do you have some custom packages?

We will appreciate these information for our tests.

Thank you
Daril


#3

Hello Daril,

I was ooo on 01/21.

Please find the below details as requested. Even now it is very slow. I just added a comment in description page in the model properties and when I try to save my comments using apply and ok button. It took more time finally I killed the session.

I have TDM 6.5.4 version

Database: MySQL 5.0
Count:
Entity: 484
Attributes:5926
Keys: 484
Indexes: 568
Relationships: 1493
View: 4
Stored Procedure: 20
Number of Workspace: 416

Note: I am not familiar with custom package.

Thanks !!
Rajesh


#4

At the first sight you have a lot of Workspaces. It is almost one workspace for one Entity.
Could you try to delete some of them if problem will disappear?
I presume, that you have not open a lot of workspaces, because it should be problem.
We normally not tested model that has more than 30 workspaces.

Daril


#5

Hello Daryl,

After seeing your reply to my post, I tested my other data model [Lets assume model B]. Model B has 46 workspaces. I did some edit to this model, but TDM is struggling to save my work.

In other TDM file [ Let’s assume model A], model A has 416 workspaces.

Model A – 416 Workspaces – Created 05/11/2018 – Last Modified 01/22/2019

Model B – 46 Workspaces – Created 11/28/2018 – Last Modified 01/17/2019

Please direct me if my understanding is not correct:

  1. You said you have not tested model which has more than 30 workspace – Does this means that TDM file should have only less than 30 workspaces?
  2. If so how I am able to create 400 plus workspaces in Model A without any performance issue? I started getting this issue since 01/18/2019.
  3. Is there any limitation on workspace count ?

In Model A – Business requirements is to create multiple ER diagrams in separate workspace, that’s the reason it took me to create 416 workspaces. I will try to minimize the workspace count, maybe one or two. Out of 416 it’s a BIG challenge to reduce the count to 30.

Please advise if there is any work around to fix this issue, at this moment I am unable to work on any existing TDM file.

I dropped 4 workspaces and saved the file, later when I do model verification – TDM got stuck. Let me know if you need the model to test.

Note: I took this issue to Toad technical team SR Number:4435105. Rod from technical support connected with me on 01/22 in webex and helped me to uninstall and reinstall TDM 6.5.4, assuming reinstallation will fix this issue. But no luck.

I found a thread related to limitation on workspace, please find the attached screen snap.


Thanks !!
Rajesh


#6

Helo Raajesh,
if you are willing to send me your model to test it will be best. Please send it to petr.daricek@quest.com and I will do performance test and I hope that I discover where is problem.
In fact it is impossible to test all combination. Yesterday I tested model with 400 Workspaces, but save model time was about 5 second. We tested a lot of models, but usually it has no more than 30 workspaces.
Another tip, can be divide model to more models and use External Object feature (place to one model entity from other) .

Thank you for cooperation
Daril


#7

Daril,

I will send my data model shortly to test upon discussing few points here with my team.

Well… I have not used other option dividing models and using external object feature. Could you please send me the steps or if there is any document please share it with me.

Thanks !!
Rajesh


#8

For external objects I recommend to see these videos


and

Daril


#9

Daril,

Thanks for sharing the videos. I sent my TDM file to petr.daricek@quest.com.

Thanks !!
Rajesh


#10

Hello Rajesh,
I received your model. Thank you.
I do some test on version 6.5.5.6 (It is the last released version) and it is relative fast. Editing majority of entities are less than 3-5 seconds after apply/ok button. Save model less than 10 seconds.
So I focused on company entity, because it is on most workspaces and it is has a lot of relationships. When I changed Length property of its attribute “id” and do apply, it takes me about 30 seconds. It is relative high value, but you know customer entity has more than 300 relationships and because id attribute is in PK, it must propagate to all child entities etc.
When I open about 20 designers with customer entity and do this action again it takes about 60 seconds(Twice more).
So my recommendation is close so many designers as you can. You can right click on tab of designers and choose “Close Other Tabs”.
image

Please let me know if it helps. If no could you please let me know exactly action what you do?

My computer has
image

with Windows 10

Btw.: I presume you have standard layout.

Regards Daril


#11

Hi Daril,

Good Morning !!
Thanks for reverting back, currently I am using TDM 6.5.4. I found the latest version 6.5.5, let me upgrade in my machine and will keep you updated.

My computer has :

image
With Windows 10. Do I need to change the RAM to 32GB ?

Thanks !!
Rajesh


#12

Hi Daril,

I upgraded TDM to the latest version 6.5.5.

Now, I am able to save my edits in the existing TDM file. However, I am unable to generate change script between 2 models.

Tried below option to have change script.

Option 1: Right clicking on Entity which has relationship – Change Script – Run [ I believe it’s a known issue handled in TDM-4866 ]
0125-Change%20script%20error%20message

Option 2: From Menu Model – Generate Change Script.
In this option, TDM performance is very slow. It forcing to kill the session.

Rajesh


#13

Hello Raaj,
We tested your model and change script. We tested on more machines.
First Machine
i7-2600 CPU 3,4GHz, 8GB RAM, SSD disc
Second Machine
i7 CPU, 2,3GHz, 16MB RAM, SSD disc
Both have Windows 10.

Change script from Main menu has duration about 10-15 minutes that is normal time on so large model.
You can divide Alter Script operations by reverse db in first step and in second step do Change Script between two models.
I don’t know if in your case is TDM Freeze or operation take a long time(It’s look like freeze but TDM still something do). You can find out it from Windows Task Manager. When TDM process has 0 percent CPU(or very low value), it means TDM is freeze.
Example:
image

But if it do something you need to way.
You can log progress to log file to see what objects are processed


You can find log in
c:\Users\XXX\Documents\Toad Data Modeler\Logs\

TDM-4866 will be fixed in next Beta.

Daril


#14

Hello Daril,

I am able to generate change script if I check the “Log Progress to File”, it takes 15-20mins. I have not changed the RAM size in my machine, however its working fine.
a. I am able to edit and save my model file
b. I am able to generate change script by enabling log progress to file.

Clarification from your comments:
Alter Script operations by reverse db in first step and in second step do Change Script between two models - I have not used the first step. Could you please elaborate on this first step.

Need your suggestion for the below:
Whenever I edit my data model by adding a table or by adding a column, I am adding the comments in the model properties – Description tab. See attached

a. Will this be one of the reason for TDM slow performance?
b. Does TDM has any other option to record the changes we make in the existing file?

Thanks !!
Rajesh


#15

Hello Rajesh,
I am glad that you are able to generate change script.

Change Script by RE first
When you generate change script in TDM you can choose if you want generate it

  1. Model and Model
  2. Model and Database
    More people choose generate Model and Database. But in this step the Change script process need to do RE to on background. So you can divide it to two part. At first do Re of your database and second do Change script Model and Model. It should be good when your change script operation is time consuming and you do it repeatable or when you try to find some problem in change script. But you should get same result in both ways.

Reason of Slow
At this time we didn’t profiling your model at all(It is time consuming) so I’m not sure the main reasons. But I can exclude, that it can be due Model Description. You can track your work on this tab without worry.
I think the reason is some tables that has a lot of relations. You know in TDM some changes are propagate from attributes in PK to child entities. So when you do some change in attributes that has a lot of child attributes TDM do a lot of synchronization between parent and child entity.
Generate Change script is the most hard to performance operation in TDM, so 10-15 minutes on large model is normal.

best regards
Daril