Formatter has stopped working

I am using Toad 17 but had this same issue in previous versions. We have a couple of large packages 8,000+ lines when I try to use formatter it takes a second then returns the cursor and doesn't do anything. Normally I would just say it was too much and move on, but it seems like from then on it doesn't work on anything else either. Such as the example I am looking at was originally in one of the big packages but I separated it into its own procedure that is only 71 lines and it won't format it.

It acts like a process got hung so I rebooted my computer but still no luck. It worked perfectly up until that bigger package and at some point it will work again if it follows the pattern of 16, I am just not sure how or why this is occurring.

There are no errors in the procedure, it compiles as expected.

Hi Keith, I know this is something you don't want to read, but we will need something reproducible on our end in order to fix this.

If you can send us code that is syntactically correct I think that should work. It does not need to compile.

If you are able to do this you can send it directly to me,

Additional information: I tried running a code analyze with SQL Scan and it returns that I have 9 invalid SQL because the sequence doesn't exist but it certainly does and it compiles just fine from within Toad and SQLPlus. I wonder if it thinks there is an error so it stops the formatter on the first one so the highlighter can show me the problem (like it always has) but the code to highlight doesn't see anything wrong so it just acts weird?

Epilogue ... After examining Keith's code it turns out that formatter is having a problem with some comment. Will sure be fixed asap.


1 Like

Is there any update or workaround? We recently installed v.17, and I'm assuming we have the same problem. I use the formatter feature daily - well, I used to use it daily when it reliably worked :-). It's beyond frustrating.

Thanks - J

Ok, you're right, and I hate frustration too. There's a fix about ready but it hasn't made it yet, probably due to other priorities. But let me have a look. I'll prioritize it.


Probably unrelated but FYI, we (well, @mstaszew) discovered today that Automation Designer formatter actions only change the case and not format. This only affects formatting done from Automation Designer. Not Editor or anywhere else. It will be fixed in Monday's beta.