Formatting fails in 16.1

There is a formatting problem with cursor for loops.
It works fine in 16.0

Welcome back to the forum!

I personally can't see any obvious issues with formatting, at least not for the cursor examples I ran through. Can you be more specific to define what "problem" means?

Would be helpful if you let us know where you're trying to format the code, and post your example before formatting, and then after formatting, or post any error messages or other such weirdness that may have happened.

Well there IS a problem indeed which was just signaled to me by our support colleague Zaida.

It turns out that the following snippet (extracted from the customer's code) :

    FOR rec IN (SELECT t1.*
                  FROM   import_csv t1 

does not format whenever the option 'Spacing -> Newlines -> Position DO/LOOP on the same line' is set, AND ALSO whenever the IN(...) clause contains something that is formatted to more than one line, such as a SELECT statements.

I fixed it today (QP-4013).

Is that what we're talking about?


Yes, it seems to be the same problem.

What does it mean that it is fixed?

When can we have a fix?

New parser version is expected this week and then it's up to the Toad team to adopt it (in the beta).


Fixed in component QP5.DLL version 5.391. Normally soon in Toad.