Toad World® Forums

freeware version expired on 29/12/1899

I just install toad data modeler freeware version today.

When it first run program, I get "Invalid or expired freeware license".

Can anyone help me,please.

Hi,

I tried now both freeware versions and it is OK.

Have you installed another Toad product or any older TDM? It’s look like TDM try load some other license. TDM accept some licenses from Toad for Oracle, Toad for DB2, Toad for SAP and Toad for SQL Server. License keys are store in file ProductLicenses.xml on Windows 7 is stored in locations:

c:\ProgramData{08439167-4CA5-48E9-A810-A3A7C0B80B06}
c:\Users\XXX\AppData\Local{08439167-4CA5-48E9-A810-A3A7C0B80B06}\

In other OS are in similar locations you can try Find file ProductLicenses.xml.

My Idea is try to delete this file (before please backup it) and try run TDM again. Let me know if it help.

From screenshot it’s look like Windows XP, is it true?

Daril

Thank you for your help, yes my OS is XP.

I’ve installed toad extension for eclipse, not toad data modeler.

Window XP doesn’t have Appdata folder, and I’ve check Application data folder.

I’ve found only Configuration X86 1 folder, not {08439167-4CA5-48E9-A810-A3A7C0B80B06}.

It can’t be found anywhere. I’ve no idea what I can do.

Hi,

we cannot reproduce it, only when I manually change value in widows registry. Could you provide your procedure exactly? Any shift with date or more version of TDM Freeware products, or something else?

Windows XP is not officially supported system for Toad Data Modeler. I have one virtual Machine with Windows XP 32b Service Pack 3, and I tested there and it is works.

You can try this procedure:

  1. Uninstall Toad Data Modeler Freeware
  2. Run regedit from windows and find key HKEY_LOCAL_MACHINE\SOFTWARE\Dell\Toad Data Modeler Freeware and delete this key.
  3. Install TDM Again

Daril

I think it may be because I change regional and language to be thai datetime (B.E. not C.E.).

I’m not sure but I will install it again with my Windows 7 laptop,that I set to U.S. datetime.

Thanks for your help.