Toad World® Forums

Have Editor Options Changed Regarding Plain Text Pasting?


#1

I noticed this a while ago but thought it was an issue with Oracle Forms rather than Toad but a colleague has raised it with me today since upgrading from 12.10 to 12.12…

If you write a statement with carriage returns and then copy it into a plain text editor, it loses those carriage returns (I was writing and copying statements into the record group query section of Oracle Forms but it can just as easily be Notepad)

E.g.

Select Sysdate

From Dual;

In Notepad becomes:

Select SysdateFrom Dual;

But if I paste it into Notepad++ and then recopy it to my clipboard and paste it into Notepad, it becomes:

Select Sysdate
From Dual;

Back in 12.10, this didn’t happen - the formatting was retained but from 12.11 onwards the behaviour is different.

I have “Copy text in rich text format” checked in both 12.10 and the latest beta.

Thanks,

Mark.


#2

Toad’s EOL mode is set to Unix (LF). You can change this in Options on the Files|General page or via rt-click EOL Conversion in Editor. Notepad and Oracle Forms require CRLF. Notepad++, on the other, converts newlines to its EOL mode so it can handle it. In Notepad++ if you set Edit|EOL Conversion to Unix (LF) and copy/paste from there to Notepad and Oracle Forms you should see the same.

This is a new behavior since 12.10. Older Toad’s had a Unix style save option. This option would set newlines to LF when saving if checked and to CRLF if unchecked. It had the undesired effect of not retaining the EOL mode of files when loaded. For example, the option was unchecked and you load a file having LF newlines. You edit and save. The LF would be converted to CRLF. The behavior now will set the default newline mode of the Editor and it has a real effect on the raw text so that newlines are preserved no matter how text is extracted. It will also preserve newlines of files so that newline corruption is no longer possible.

You may be able to set the default EOL mode to Windows (CRLF) and be OK, now. You will be able to work with existing files having LF newlines without corruption. When creating new files if they are destined for a system requiring LF newlines then rt-click and set the EOL mode.

Michael


#3

Thanks Michael, I’ve set the default EOL mode to Windows (CRLF) and it works fine. I don’t think I’d have found that option without your direction!


#4

You’re welcome. It’s in a screwy location that’s for sure. It may make more sense in Editor|Behavior, but it’s one of those options that affects areas other than the Editor.