Toad World® Forums

Problems with 10.6


#1

Hi

I’ve just installed 10.6 and I love some new things (split window in editor,
easy comparing using ctrl+drag, no more splitting qualified names) but there are
a couple of issues.

1 - Every time I go to a new tab in the editor window if I have the Data Grid
view folded down at the bottom of the screen it feels the need to scroll up and
down at its usual (far to slow) speed. This is getting very irritating very
quickly.

2 - We keep our packages in a single file so the format goes:

create or replace package yadda
is
......
end yadda;
/
/**/

create or replace package body yadda
is
....
end yadda;
/

Now when I format the header tab it removes the trailing line feed after the
slash so what I get is:

end yadda;
//**/

create or replace package body yadda
is

I can’t find any option to turn this off and it’s potentially quite dangerous.

Thanks

Dan


#2

For issue 2


#3

Dear Toad users,

After looking through Toad’s online help, and doing a help search on ‘font’ and
then spending 2 hours searching with both Google and Bing, I still can not find
where to set the font so that when I copy/paste out of my TOAD editor window TO
an Outlook Email (or word doc) it does not give me that damn MS Shell Dlg 2
font.

Sorry that I’m a little pissed off, but you would think that the developers
would know that


#4

Search options for rich text format.

For starters it would help to have an understanding of the clipboard and how it
is treated by applications. When you put normal text on the clipboard then all
that is present is the text. It is up to your application receiving the
clipboard contents via paste to set the font. So, in Outlook if the font is not
as you want it then chances are you have set the font in a way that you do not
like. If you copy text as rich text format then a different clipboard format is
used that retains syntax coloring, font selection, etc. If you enable that
option then your Toad font will be retained in Outlook as will your syntax
highlighting and other display properties.

Michael


#5

Michael,

Thanks so much for the reply. The fact that the colors are retained would lead
me to believe that rich text is being used.

Here is a small example assuming you are not converting to simple text:

/* Formatted on 9/17/2010 10:01:14 AM (QP5 v5.149.1003.31008) */

SELECT ‘Michael’

FROM DUAL

WHERE dummy = ‘X’ ;

Everything seems to be properly retained except for the font.

Do you know if there is a setting in TOAD or elsewhere that will allow me to
retain the font?

Michael J. Moore

PL/SQL Developer


#6

I discovered that I still have version 9.2 on this same machine which gives:

SELECT ‘Michael’

FROM DUAL

WHERE dummy = ‘X’ ;

when I paste. I don’t know if yahoogroups or your email client will translate
this as I see it right now, but fyi, what I am seeing in the email is exactly as
it appears in the TOAD editor window … all colors retained and Courier font
retained.

So what option on my 9.2 install is different than on my 10.5 install?

I know that I set this parameter, I just can’t remember how to get back to it.

thanks,

Michael J. Moore

PL/SQL Developer


#7

Verify that your Toad font is set correctly. Options|Editor|Display. If you are
on a normal English copy of Windows and you see Tahoma as your Editor font then
it is the same as MS Shell Dlg2. As I understand it, MS Shell Dlg2 is a pointer
so to speak for Tahoma in your Windows installation. Other installations of
Windows, in particular those for users in other countries or those using a
non-English (maybe American English) Locale will have MS Shell Dlg2 mapped to
something else. When I take a normal, default copy of Toad 10.1/5/6 and copy in
rich text format and paste into Outlook I see MS Shell Dlg2 exactly as you are
showing. It sounds like your Toad font selection is not fixed width as you
intend. The default font selection was changed to MS Shell Dlg2 a few releases
back for full Unicode support out of the box.

Michael


#8

Hi Michael,

Sorry if I am sounding a little dense but if I understand you correctly you are
telling me to

Dear Toad users,

After looking through Toad’s online help, and doing a help search on ‘font’ and
then spending 2 hours searching with both Google and Bing, I still can not find
where to set the font so that when I copy/paste out of my TOAD editor window TO
an Outlook Email (or word doc) it does not give me that damn MS Shell Dlg 2
font.

Sorry that I’m a little pissed off, but you would think that the developers
would know that

  1. I never want to copy/paste from a non-proportional font to a proportional
    one.

  2. Since this is a super obvious annoyance, it would be super easy to find the
    solution in the TOAD help files.

Now that that’s off my chest, would somebody be so kind as to tell me where the
option is to retain the current font during the copy/paste operations described
above? I know that it’s doable because I’ve done it on earlier versions of TOAD.

My current version is: 10.5.1.3

And again, my apologies to TOAD developers, I know they work really hard to make
finding things easy.

Michael J. Moore

PL/SQL Developer


#9

I will need to check the old version against the new and see what differences
there are. In short there is no way to change the clipboard font. If there are
diffs between an older version of Toad and the current then it may be due to an
Editor upgrade that we did a few years back.


#10

Ok, Thanks again Michael,

In closing, let me say:

Hi Michael,

Sorry if I am sounding a little dense but if I understand you correctly you are
telling me to

  1. Go to Options|Editor|Display and set the font to Tahoma.

I went to Options|Editor|Display and found that my font was set to Courier
(which is what I want) so I set it to Tahoma. The result was terrible. Tahoma is
proportional (not fixed) so the result was that all of me Editor windows now
show ‘iiiiiiii’ as taking up half the space of ‘HHHHHHHH’. Obviously this is
inaccaptable for coding so I set it back to Courier.

I must not be understanding correctly what you are asking me to do.

Michael J. Moore

PL/SQL Developer


#11

You said “in closing” but I’m going to reopen it. I just
copied and pasted text from a Toad 10.6.0.42 editor into both Outlook and Word,
and it came through in each case in a combination of Courier and Courier New
(which is a different puzzle, why the comments are Courier but the rest is
Courier New). So it can be done. So the question is: what do I have set
differently from you? Editor/Display/Fonts/Editor is Courier New, regular, 9
point; Editor/Behavior/Languages/PLSQL/Highlighting/practically everything/Style
type: default font. Or maybe it’s an option somewhere in Word? Word
Options, Advanced, Cut Copy and Paste, Pasting from other programs, Keep source
formatting; and the same in Outlook Editor Options.

Nate Schroeder

US Seed & Trait Commercial IT - Data Management Team

Monsanto Company

800 N. Lindbergh Blvd. LC4D - Saint Louis, MO - 63167

314-694-2592

This e-mail message may contain privileged and/or confidential information, and is intended to be received only by persons entitled to receive such information. If you have received this e-mail in error, please notify the sender immediately. Please delete it and all attachments from any servers, hard drives or any other media. Other use of this e-mail by you is strictly prohibited.

All e-mails and attachments sent and received are subject to monitoring, reading and archival by Monsanto, including its subsidiaries. The recipient of this e-mail is solely responsible for checking for the presence of “Viruses” or other “Malware”. Monsanto, along with its subsidiaries, accepts no liability for any damage caused by any such code transmitted by or accompanying this e-mail or any attachment.

The information contained in this email may be subject to the export control laws and regulations of the United States, potentially including but not limited to the Export Administration Regulations (“EAR”) and sanctions regulations issued by the U.S. Department of Treasury, Office of Foreign Asset Controls (“OFAC”). As a recipient of this information you are obligated to comply with all applicable U.S. export laws and regulations.


#12

Hi Nate,

I tried Courier New, regular, 9 point but no change. As for the theory that it
could be a Outlook or Word option, the fact that my TOAD V9 ( which is on the
same desktop maching as my TOAD V10) properly retains the font, would seem to be
evidence to the contrary.

Thanks for your effort!

Michael J. Moore

PL/SQL Developer


#13

Try looking for the option in OUTLOOK!

http://screencast.com/t/NzNkYmZmZTE

Joseph E. Meyers I
Banner Support Specialist / Adjunct Lecturer
Cayuga Community College
197 Franklin Street T331
Auburn, NY 13021
AIM /EMAIL: joe.meyers@cayuga-cc.edu
(phone) 315-255-1792 x2270
image003.png


#14

It is ticked. In fact I’ve got every single box on that page ticked except for “Suppress blank line after indenting / before unindenting keywords”


#15

I have the same issue, and you solution does not fix the solution.

FYI: This was broken about a year ago and it was fixed, now it is back.