Toad World® Forums

Have problem with Navigator 6.1 with Oracle 12 installation


#1

Good day all,

I registered on this group only today - 7 May 2018.I never knew this group existed and only found it due to searching for problems I have with SQL Navigator 6.1 and 7.1.

I have been using SQL Navigator since early 2000’s since V3, and have the last few years been working on SQL Navigator 6.1.

This worked fine for me for many years until our company recently installed Oracle 12. I have now issues with 6.1 in that I can not open, view or edit procedures and packages.

I would like to know what causes this, and is there a setting that can fix this ? (For V 6.1).

When I attempt to open a package, I get this message : example

12:06:15 PACKAGE “PR_AM”.“PKG_CALL_CITY_1” recreated
12:06:15 PACKAGE BODY “PR_AM”.“PKG_CALL_CITY_1” not found


Then, in my attempts to get past this problem, our company had a V7.1 installation file, quite a few years old. I then installed V7.1. After my install the license was automatically upgraded from 6.3 as valid license, and I could work on V7.1. But I got many problems, and the nr one problem is that Navigator becomes unstable after I do almost nothing and prg crashes.

I then read up on Google and saw there were some similar problems with V7.1 release which were solved on later installations.

I now see V7.4 is available. I now want to install V7.4, but where do I get the installation files ? I do see the installation downloads on Quest website, but they require the client information and detail first, before I am allowed to download the software. I do not have this detail, as I do not know exactly and with what detail my company registered with Quest many years ago.

I just want the download file, preferably for 32 bit and 64, and I am quite sure our license will cover this upgrade. If not the software will tell me, and I can then pursue this further with our company.


I would have no problem carrying on with V6.1, if someone can tell me why I can not open procedures and package.

We do have licensed PL/SQL Developer as well that we use for development, but I am a big SQL Navigator fan.

Thank you for any help.


#2

Hi,

Thanks for your feedback.

For v6.1 version, it didn’t support oracle 12 since it was old version, we suggest that upgrade to latest versions which have both 32bit and 64bit.

And you can download latest beta version from: https://community.toadworld.com/products/sql-navigator/sql_navigator_beta_program/

have a try our latest beta and see if work for you.

Thanks,

Michael


#3

Morning Michael,

Thank you for your reply.

I see that on this 32 bit download in the link you provided, it says expiring 31 May 2018. What does this mean ? Does this mean I won’t be able to work on the software after 31 May 2018 ?

Download Beta build 73 expiring on 31-May-2018

Also, does the Beta versions mean that V7 is not yet fully finalized to be used, or launched, and still in development ?

If so, which is the last version that I can use full time, before the Beta versions, that will work on Oracle 12 ?

Thank you for your help.

W.S.


#4

Hi,

Yes, v7.5 beta will be expire 31 May 2018, and we also will prepare a new v7.5 beta to community in this month

Last version was v7.4 which you can use it full time, that will work on Oracle 12

Hope that can help you

Michael


#5

Michael, thank you for your reply.

It puts me back to square one, as I do not know from where to download V7.4 ?

Also, which is the download build I must use ? and what is the URL to download that file, please ? One that has not expired in the past.

I searched previous message in this forum and see a 7.4 build 33, but it also says expire on a certain date in the past.expiring on 30-Apr-2017

Note, I am looking for the 32 bit one. If there are 2 links for both 32 bit and 64 bit, can I have both please.

Thank you again for your help.


#6

https://community.toadworld.com/products/sql-navigator/ (this is the same as clicking on the ‘Overview’ tab at the left of the Forum tab). From there you can upgrade or download the current Trial version and test that.

If you go to the BETA tab at the top of this page you will see the Beta drop there.


#7

Hi,

For more product info, you can go to https://www.quest.com/ and https://support.quest.com/download-install-detail/6080802

Thanks,

Michael