How can I remove the name of the database from the Generates SQL feature?


i am using a ODBC connection to a HIVE environment. When I use the GENERAL SQL feature from one of the tables the query adds the name of the database in this case HIVE and then the schema and the table so it will be something like:

SELECT * FROM HIVE.schema_name.table_name

The problem is that it will fail and I have to remove the HIVE for the query to work so:

SELECT * FROM schema_name.table_name

When I try to pull the data in the Explorer it also gives an error.

Is there a way to change the settings so the Generate SQL or any query done does not include the database name?

Than you

I don’t think there is an option for it. Did you try create a HIVE connection directly instead of using ODBC?