Toad World® Forums

How is it possible to delete data on timestamp(6) column from schema browser

Hi

Version: 13.3.0.181

I am unable to delete data from timestamp(6) column from schema browser.

For example, when I have date or varchar, etc column, then to edit the column, I just double click it and then I can modify it. To delete it, I just click onto the column once and press backspace. And commit it.

Issue 1.
But with timestamp column, this does not work.
If I try to delete data from certain row's column, then I click onto it once and press backspace. You'll notice that date still stays present there and cursor goes into first position.
Now if I delete manually this date there, and click onto another row or commit, then I get:

ORA-01847: day of month must be between 1 and last day of month

Here's an example, what I do:

image

Actually the timestamp is not gone here. What here happens basically is described on issue 2 also. The backspace actually does nothing at all here. So the date and timestamp are both there, and if I delete the date part (from that picture it does seem like time part is deleted already), then time still is present (if I move my cursor to the right side, then I can see it, it is just hidden there) and probably that is why I get this ORA error. So what I need to do, is slowly double click the column and CTRL+A and delete.

Issue 2
If editing data with timestamp column via schema browser I have another problem. Which I will illustrate via picture.

I know that this behaviour has been present for quite some time, just hadn't time to report it.

E: The heading is bit misleading, as now I know how can I achieve this, since when writing this "Issue 2" part, then I discovered how it is possible.
But still, it is strange that it behaves like that, perhaps there is something to be done.

Raul

I do see what appears to be some anomalies here, possibly because of the way Oracle is storing the timestamp. Until the Quest dev team adds some clarity, and for now as a work-around, you can bring up the Single Record Viewer (right-click on your data to choose it). This is a viewing pane from which you can navigate to any record, and make your edits. I did notice that even in the Single Record Viewer you will need to press Ctl-A to highlight the entire timestamp field (double-click doesn't work) and then your backspace/delete keys will function.

Once you have the cell in edit mode, highlight the entire cell contents, the delete key on your keyboard.

Note, this is different than the entire cell contents being highlighted when you are NOT in edit mode.

You want the highlight to look like this before hitting delete:
image

Not this
image

All that said, it does seem buggy that you can't backspace it to nothing to do the same thing. I'll try to fix that.

Edit: I got the error one time, but the 2nd time, backspace worked just fine. hmm.

Also, I haven't been able to reproduce the problem of time disappearing, even when I size the column small enough to barely show date+time in the format you have above. There may be some other factor involved.

Thanks..:slight_smile:

Hmm, you mean clicking into column just once and then backspace deleted whole timestamp..?
If so, then it is strange, for me, the backspace does absolutely nothing, only cursor is places in the first position (then I have to ctrl+a and press backspace or delete from keyboard).

For this, I do have noticed, that for the first time I do this for certain row timestamp column, it will just move cursor to the first position and it shows whole timestamp just fine. But if you then "Esc" and do the same thing for the same row column, then it will hide time part. And the same behviour applies to that row column if I repeat the same process.
If you choose new row timestamp column (where you haven't tried this before), then the first time it's different again, but other times it (hiding time part after pressing backspace) does occur for me at least.

Raul

Did this one get resolved as well some how..?

Raul

Yes. Let me know if you need to find out exactly when it was fixed.

1 Like

Thanks, knowing its fixed, is good enough for me.

Thanks.

Raul