Toad World® Forums

How to change 'NOSCALE' default on table creation

Hi,
I have a developer that is creating some tables thru TOAD that have a identifier column. When he does this, the script puts the keyword 'noscale' in the sql. The SQL fails and then he removes the 'noscale' and reruns successfully.

Is there a place in TOAD where you can tell it not to put that keyword in there?

Here is the SQL and error message:

CREATE TABLE TRREPORTING.DOCUMENT_SALLIETEST
(
ID NUMBER GENERATED ALWAYS AS IDENTITY ( START WITH 289491 INCREMENT BY 3 MAXVALUE 9999999999999999999999999999 MINVALUE 1 CYCLE CACHE 20 ORDER KEEP NOSCALE) NOT NULL,
FILENAME VARCHAR2(255 BYTE) NOT NULL,
APPLICATION_ID NUMBER NOT NULL,
DOCUMENT_TYPE_ID NUMBER NOT NULL,
DESCRIPTION VARCHAR2(200 BYTE),
TIMESTAMP DATE DEFAULT SYSTIMESTAMP,
LOCATION NUMBER,
LEGACY_IMAGE_ID NUMBER,
JURISDICTION_ID NUMBER,
DOCUMENT BLOB,
USER_NAME VARCHAR2(254 BYTE)
)
Error at line 3
ORA-02000: missing ) keyword

Has anyone else run into this?

Thanks,
Sallie Cottingham

Hi Sallie,

NOSCALE should only appear for Oracle 12cR2 and newer. With version 12.1 it will cause an error.

I just tried with Toad 14 beta to get this keyword to appear when using Oracle version 12.1 but could not. Please let me know how you did that.

If you are creating a script from a newer version of Oracle and want to run it on an older version of Oracle, you can make the script compatible with the older version with this option:

Hi John –

The developer changed the parameter that you highlighted and got it working as expected. I thought we had clicked on every button in TOAD looking for something but I guess not – lol!

Thank you so much for your quick response!

image001.png

image002.png