Toad World® Forums

how to connect to enable ssl for PostgreSQL reverse engineering in TOAD DM


#1

Similar to this post for standard TOAD --> http://www.toadworld.com/products/toad-mac-edition/f/109/p/22606/48641#48641

I need to connect my Toad DM 5.4 model to a Postgresql 9 instance in Heroku, which requires SSL. There is no option for SSL that appears in the connections screen, and none of my attempts to add a connection string parameter (e.g. SSL=True or UseSSL=True) have worked. I keep getting the message : “Connection failed because of the following error: “no pg_hba.conf entry for host “xx.xxx.xxx.xx”, user 'asldfkjdslfkadsfl”, database “lksdfjsdlsdlfjk”, SSL off” I know I need to enable SSL for any connection to my Heroku hosted PostgreSQL database, but I can’t figure out how to do this in the TOAD DM Connections setup.


#2

Hello Paul,

Unfortunately, it is currently not possible to enforce SSL PostgreSQL connection, even when using custom connection string. I have created a CR TDM-1739 to implement direct support for SSL connections, so you should be able to connect to your database in one of the future versions of TDM.

Regards,

Lukas


#3

Possible workaround: It might be possible to establish SSL connection via psqlODBC driver 8.01.002 and later (without certificate). Please give it a try.

Regards,

Vaclav