Toad World® Forums

How to connect toad on windows to linux


#1

Message from: ramya

hey… i have the toad installed on windows 7… and i have the linux database
with oracle 11g. and i want yo connect toad on windows to linux database by
using listener file… How can i connect …? can u plz explain th way how i can
connect?? thanx


Historical Messages

Author: ramyak
Date: Sat Jan 29 12:06:23 PST 2011
hey… i have the toad installed on windows 7… and i have the linux database
with oracle 11g. and i want yo connect toad on windows to linux database by
using listener file… How can i connect …? can u plz explain th way how i can
connect?? thanx
__



#2

Afternoon,

assumptions:

Linux server is named TUX. Listener is running on this box at port 1555.
The database is called tux11g. Your desktop is using TNSNAMES.ORA to
resolve database alias names into server/port/sid-service and protocol.

On your desktop:

  • Ping tux. If you get a result, good. If not, you need to get your sys
    admins to add tux to the DNS system or the local hosts file on Windows
    7, wherever that lives!

  • Edit your tnsnames.ora file found under /network/admin on
    your desktop. Add the following:

tux11g.world =
(DESCRIPTION =
(ADDRESS = (PROTOCOL = TCP)(HOST = tux)(PORT = 1555))
(CONNECT_DATA =
(SERVER = DEDICATED)
(SERVICE_NAME = tux11g)
)
)

Note that “.world” is as per defined in sqlnet.ora (in the same
directory) under the setting:

NAMES.DEFAULT_DOMAIN = world

Please check the setting:

NAMES.DIRECTORY_PATH= (tnsnames)

It can have other stuff in brackets, but make sure tnsnames is found.

  • In a cmd session on the Windows desktop, run a “tnsping tux11g”
    command. You should get a response of “TNS-03505: Failed to resolve
    name” then there is a problem that needs to be resolved because your
    client is not reading the sqlnet or tnsnames files.

Assuming you get this instead:

Attempting to contact
(DESCRIPTION=(SOURCE_ROUTE=OFF)(ADDRESS_LIST=(ADDRESS=(PRO
TOCOL=TCP)(HOST=tux)(PORT=1555)))(CONNECT_DATA=(SREVICE=tux11g)(SERVER=D
EDIC
ATED)))
OK (20 msec)

Then you are there!

Start Toad and login to a username and password on database tux11g and
you are done.

HTH

Cheers,
Norm. [TeamT]

Information in this message may be confidential and may be legally privileged. If you have received this message by mistake, please notify the sender immediately, delete it and do not copy it to anyone else.

We have checked this email and its attachments for viruses. But you should still check any attachment before opening it.
We may have to make this message and any reply to it public if asked to under the Freedom of Information Act, Data Protection Act or for litigation. Email messages and attachments sent to or from any Environment Agency address may also be accessed by someone other than the sender or recipient, for business purposes.

If we have sent you information and you wish to use it please read our terms and conditions which you can get by calling us on 08708 506 506. Find out more about the Environment Agency at www.environment-agency.gov.uk


#3

On top of Norms detailed instructions I would also want to point out
that the Oracle client you have installed is the 32-bit version and
not the 64-bit one. Toad is 32-bit app and will not work with the
64-bit client.

Ed
[TeamT]

On 1/31/2011 9:35 AM, Dunbar, Norman (Capgemini) wrote:

Afternoon,

assumptions:

Linux server is named TUX. Listener is running on this box at port 1555.
The database is called tux11g. Your desktop is using TNSNAMES.ORA to
resolve database alias names into server/port/sid-service and protocol.

On your desktop:

  • Ping tux. If you get a result, good. If not, you need to get your sys
    admins to add tux to the DNS system or the local hosts file on Windows
    7, wherever that lives!

  • Edit your tnsnames.ora file found under/network/admin on
    your desktop. Add the following:

tux11g.world =
(DESCRIPTION =
(ADDRESS = (PROTOCOL = TCP)(HOST = tux)(PORT = 1555))
(CONNECT_DATA =
(SERVER = DEDICATED)
(SERVICE_NAME = tux11g)
)
)

Note that “.world” is as per defined in sqlnet.ora (in the same
directory) under the setting:

NAMES.DEFAULT_DOMAIN = world

Please check the setting:

NAMES.DIRECTORY_PATH= (tnsnames)

It can have other stuff in brackets, but make sure tnsnames is found.

  • In a cmd session on the Windows desktop, run a “tnsping tux11g”
    command. You should get a response of “TNS-03505: Failed to resolve
    name” then there is a problem that needs to be resolved because your
    client is not reading the sqlnet or tnsnames files.

Assuming you get this instead:

Attempting to contact
(DESCRIPTION=(SOURCE_ROUTE=OFF)(ADDRESS_LIST=(ADDRESS=(PRO
TOCOL=TCP)(HOST=tux)(PORT=1555)))(CONNECT_DATA=(SREVICE=tux11g)(SERVER=D
EDIC
ATED)))
OK (20 msec)

Then you are there!

Start Toad and login to a username and password on database tux11g and
you are done.

HTH

Cheers,
Norm. [TeamT]


#4

As a note added to Norm’s instructions, a suggestion:

Toad is not an Oracle client itself, it makes use of your Oracle client that is
installed. After you get your tnsnames set up, test connecting to the database
through the SQLPlus client first.

That way you can be sure if you run into an issue that it’s not with Toad.

Roger S.