Toad World® Forums

How to ignore the object owner when synchronizing a model with the database

Hi,

I’m trying to compare an existing database schema (Oracle) with my TDM model. Inside the TDM model I’m have not assigned a schema (DB Owner, Username) to the tables. So whenever I compare my database with my model, all entities are reported to be different, because the DB Owner is differen.t

I did not find any option in the “Synchronize Model” dialog to ignore the DB Owner (I can deselect many other items, but apparently not the DB Owner)

Any ideas how I could do that?

Currently I’m thinking about a macro as a workaround that assigns an owner to all objects before I do the sync, but that seems like a rather clumsy workaround.

Main Menu -> Tools -> Schema/Owner Assignment

Open your model, temporarily change it to the database owner so the compare will not list everyone as a hit ….

Thanks that was what I was looking for

I’m hoping dev monitors this and sees the logic of this being an compare option check box
J

Hi,

thanks for your feedback. Of course, this community is monitored :slight_smile: New change request was created (CR#112319) and we will try to prepare solution for it.

Regards,

Vaclav