Toad World® Forums

How to turn off Data Fetching in Object Explorer?


#1

When I select a table in the Object Explorer, I see “Fetching Data” below the table selection. Is Toad Data Point reading the definition of the table or all of the data in the table?
I have to wait for minutes before I can continue.

Is there a way to turn off reading the data from the table?


#2

Go to Options | Explorer | General, enter the number for retrieve objects in Object Explorer.


#3

Also I can confirm that TDP reading data only when you are on Data tab for specific table. OE reads only definition of objects.
If you want to see what SQLs are running you can go to Tool -> Execution Trace - To Output. Now you should be able to see SQLs which we using for getting definitions. If you think there is some pleblem SQL just let me know (also TDP version and information about provider).

Filip