Import from Excel - very slow

I am on
I am trying to load file with about 20K records and it takes almost an hour to load.
No constraints are enabled and no indexes are active.

Same file gets loaded in less than a minute in SQL Developer.

What could be the issue?

Did you check this box? You should. It makes all the difference for speed.

Yes, i did not try it, but did not work.

I DID try it and it did not help.

I'm not sure what could be the problem then.

I just tested with a copy of dba_source. I was able to import 20,000 records in 6 seconds.

I'd be happy to try with your excel file if you want to send it to me.

Thanks for all your help. Appreciate it.

We were able to reproduce hour-long imports with your file. This is a bug and it will be fixed in version 16.2.

Until then, as a workaround, when importing data with dates from Excel files, make sure that Toad's date format in Options -> Data Grids -> Data matches the format in Excel, and then it will be fast.

Thanks for your time on this

You're welcome. Sorry you had such slow imports. :frowning: