Toad World® Forums

Import to SAP Hana table fails after 50K rows

I am trying to import from one Locale storage table into a Hana column table.
The import fails after 50K rows has been imported:
21:53:46 Thread (1) Connecting to :dlt-hanadb...
21:53:46 Thread (17) Import Started [18.03.2020 21:53:46]
21:53:46 Thread (17) Processing "An existing table" into "NN.KURTADDR"
21:53:46 Thread (17) Importing 1 out of 1 files
21:53:46 Thread (17) Import embedded query
21:53:46 Thread (17) Import block size optimization is enabled
21:53:47 Thread (17) Change Schema to NN
21:53:54 Thread (17) Inserting row 2000 into table KURTADDR
21:54:10 Thread (17) Inserting row 6000 into table KURTADDR
21:54:40 Thread (17) Inserting row 14000 into table KURTADDR
21:55:40 Thread (17) Inserting row 30000 into table KURTADDR
21:56:55 Thread (17) Inserting row 50000 into table KURTADDR
21:56:59 Thread (17) Inserting row 51143 into table KURTADDR
21:56:59 Thread (17) Fatal error encountered during data read.
Reading from the stream has failed.
Attempted to read past the end of the stream.
21:57:12 Thread (17) Error(s) occured, 51143 out of 51143 rows were imported and have been committed.

21:57:12 Thread (17) Error importing data, please check file format options: Fatal error encountered during data read.
21:57:12 Thread (17) Import Finished [18.03.2020 21:57:12]
21:57:12 Thread (17) Import time: 00:03:25.4442140

I have tried import both from ImportExport wizard and from an Automation with same result and simalar error message.

I am running TDP 5.1 and Hana version 1.0.122.14.
My DBA thinks it is because I am holding a transaction for to long.

What do you think is wrong and how can I fix this?

I have now run the same ImportExport but this time from a copy in an Oracle database instead of from Local Storage (MySQL). This time the import to SAP Hana worked just fine. So the issue must be with MySQL.