Toad World® Forums

Invalid Connection Profile when I try to use the Auto Optimize SQL

I receive an Invalid Connection Profile when I try to use the Auto Optimize SQL on my new pc. I have Toad 12.60.053 for Oracle the Expert Edition with the DB Admin Module. Can someone point me to what I might need to configure.

Thanks

Hi kcrunkeleton,

Can you describe your situation more? For the “Invalid Connection Profile” message received, did it ONLY come from Optimizer? Can you make connection in Toad?

Also, what database version are you using? And what connection method you’ve tried in Optimizer (TNS/Direct/LDAP)?

Please let us know more about your steps.

Thanks,

Polly

The message only happens when I go to Database - Optimize- Auto Optimize SQL place a query in the Statement to Tune window and select start. I was able to do this on my old pc so it makes me think it’s a setup issue. I’m using a direct database connection in the Editor screen and it works fine. My Oracle Version is 11.2. Thanks

Hi krcunkleton,

Thanks for your information. I’ve tried to use direct method with Oracle 11.2 to make connection in Toad first, and then went to both “Database - Optimize- Auto Optimize SQL” and “Editor” to start optimizing the SQL, both worked fine for me.

Since the two ways of starting Auto-Optimize are the same, and if you can successfully make connection in Toad before doing anything else, the connection should be validated successfully already and it seems won’t related to setting up of database/environment problem.

We would like to further investigate your case.

Please create a support case for us following up your issue. You can contact our support through Help | Support Bundle.

Thanks,

Polly

I’m facing the same issue. I’m logged into my database, running a sql statement correctly. I’m clicking ‘auto optimize sql’ and I get invalid connection profile. :frowning:

Are you also using direct connection? What version of Toad?

If I recall correctly what fixed my issues was changing the connection type TNS instead of Direct once I did that it started working.

I was facing the same error, you can avoid the error using service_name instead of SID in your Direct connection