Invalid Object error on simple select * (SOLVED)

I have suddenly started experiencing NullReferenceException Object reference not set to an instance of an object on every query in SQL Server 2012 (11.0.6615 SP3). This just occurred out of the blue, and our DBA says nothing has changed in our environment on the server side.

Failed first in Toad for SQL Server 7.2 Upgraded to 7.4. Uninstalled and reinstalled. Uninstalled, deployed something else and redeployed. (This last step because I've had two recent no disk boot errors, but the SSID passed a low level HP test).

I'm stumped. Could some MS runtime be corrupt and causing this? Or something else in my environment outside of Toad?

Very strange indeed. I'm guessing with your recent boot errors that something lower level might be causing an issue here. Should be easily tested to see whether it's your workstation that's the culprit or not (assuming nothing else on the database has changed.)

  • When Toad for SQL Server is installed and used on another workstation, do you get the errors still?

  • When you point to another SQL Server instance, do you still get these errors?

If no errors in either case, then very likely it's something on your workstation, but not sure what at this point...

Otherwise, would strongly suggest you create a Quest Support ticket to get to the bottom of things.

My Data Engineer dug a little deeper here and in StackO and found a solution.

I checked my user's roaming data profiles and found that the folders for 7.2 and 7.4 persisted even after uninstall. Deleted both. Reinstalled.

Problem Solved.