Toad World® Forums

Issue with Toad auto connecting after crash


#1

Wondering if anyone has noticed the following behavior with 10.6.1.3. When restarting Toad after a crash and selecting the auto-saved editors to restore and reconnect, the editors are connecting to the wrong database. For example, say you have 4 database connections with 4 editors open, something happens and Toad is killed. Upon restarting you get prompted with 4 editors that were autosaved. You select all 4 and Toad proceeds to connect to the databases and load the autosaved scripts into the editors. Problem is, that it mismatches the scripts to the DB connections as follows:

Script 1 for DB1 - not associated with a db
Script 2 for DB2 - connected to DB1
Script 3 for DB3 - connected to DB2
Script 4 for DB4 - connected to DB3

So it like there’s a loop where the index is off by 1.

I’m running on Win7 using the Oracle11g client, in case that makes a difference.


#2

Hi Troy-

I haven’t seen that. I just tried to replicate with three databases and three
files but it worked correctly. I selected all three to recover and their three
connections were created and the three files loaded into their respective
editors.

I also tried the same thing but with the addition of an Editor window not tied
to a connection. It correctly recovered the file without creating a connection
for that Editor.

Given your example, I’m not sure what you mean “off by one.” Should one of your
Editors not have a connection tied to it?

The recovery window shows you the temp file name and the database it’s tied to.
If it’s not tied to one, that column will be blank. This data comes from the
file named ~EditorBackups.txt in your \User Files folder.

Mark


#3

Hi Troy,

This issue is fixed in the Toad 11 beta. Feel free to check it out.

Thanks,

Brad


#4

Well that explains why I couldn’t replicate it, I tried it in the beta. It was
probably even my bug that I fixed and forgot wasn’t it.


#5

Thanks. I was thinking of documenting it better and submitting a bug for it if it was something nobody had seen yet.