Lag before results are displayed in the editor's data grid


When I run queries on my editor, there is a lag before the results are displayed on the data grid. I understand that there is time spent on executing the queries itself but that isn’t the case here.

for example,

  1. I type this “select sysdate from dual”
  2. I execute it using “Ctrl+Enter” or “F9”.
  3. I see a popup for a fraction of a second before it disappears.
  4. I see the result in the data grid after ~2 seconds.

Opening a new instance of Toad doesn’t fix this. If I restart my machine, this issue is temporarily fixed before it comes back. I thought I could be running out of memory but when I look at resource monitor, I see I have ample free memory and CPU.

Is this something you can help me with?


Support Bundle for Toad for Oracle
Bundle: Toad for Oracle Xpert (64-bit), Add-Ons:
Edition: Toad for Oracle Developer Edition
Operating System: Windows 7 (Build 7601)Service Pack 1

Physical Memory Load: 19.54 %
Physical Memory (Total): 24457 MB
Physical Memory (Free): 19679 MB
Virtual Memory (Total): 8388607 MB
Virtual Memory (Free): 8387837 MB
Swap Space (Total): 48912 MB
Swap Space (Free): 43893 MB
Toad Page File Usage (Virtual Memory): 214 MB
Toad Working Set Usage (RAM): 273 MB

Anyone has a solution for this?

Is the result section pinned or does it slide up/down? There is a bit of a delay when it slides, I don't know why. If you keep it pinned, then there is no no delay. The "pin" is here, in the top right of the output section.


Thanks for replying. It is pinned.

When I start Toad, this isn’t a problem. The issue starts when its been running for a few hours. I don’t know why.

I have now tried uninstalling and installing Toad 12.12 and this issue is still there.

After the re-install, Toad works fine for a few hours and then it takes ~5 seconds to display the result for any query.

I even tried select sysdate from dual; on different databases. Same delay.

As of now, Toad is unusable for me. I would appreciate any pointers to fix this.

The only things I imported from my previous installation are my connection and auto-replace settings.


I wonder if a background session is timing out. Does it happen if you go to Options -> Oracle -> Transactions and uncheck "execute queries in threads"?

What about for a non-SELECT? Do those also take long time to execute? Try with this...


If that block is also slow please report on your SQL Recall options on the Editor|Code Assist page in Options.


Thanks for replying. The queries and execution times are fast. It is the data grid. For the following scripts, I pressed F5 (run as script) in the editor. The "Processing Script" popup window took a time to disappear but the query was fast. Here is the output:

SQL> set timing on
SQL> select sysdate from dual


1 row selected.
Elapsed: 00:00:00.02
SQL> begin
PL/SQL procedure successfully completed.
Elapsed: 00:00:00.02

My SQL Recall settings are same as in your screenshot.


Thanks for replying.

I have that option unchecked. Do you want me to check it and see if that helps?


if it's already unchecked then I don't think checking it will solve this but it won't hurt to try.

I tried. Unfortunately, that didn't help :frowning:

If it helps, I have the same lag in Toad Script Runner (Alt T + T). The processing script popup takes ~5 seconds for select sysdate from dual;

This is not a problem in sqlplus (Alt T + L). The result is instant.

I am open to trying any settings change. Thanks!!

when the lag starts, is there lag if you do something in Toad that will make it do a background query (such as open or refresh schema browser?)


I don't see a lag anywhere else in Toad. It's just the result set display in the Data Grid. In Query Viewer, the Execution Time shows 10 msecs.

I have a lot of "Auto Replace" entries. Do you think this might be causing a problem?


And just to confirm that it's the grid and not something else, disable the "Show Script Grids" option on the Scripts page in Options and then run a select as script (F5). Do you get the text output quickly?

I just restarted Toad and the problem has gone away for now (the last couple restarts did not fix it). It'll be a couple hours before I see it again.

I have disabled the "Show Script Grids" option. I'll get back to you with the results.

Thanks again both of you.

Okay, so the problem is back.

I don't know if it is the way I run my queries. I usually leave a line between my queries and press Ctrl+Enter to execute it. I am used to this for 12 years now.

This displays the results in the "Data Grid" and takes 5+ seconds.

If instead, I highlight my query and press F5, it is very fast.

F5 and Ctrl+Enter couldn't be more different under the hood. To test your Ctrl+Enter vs. not then use F9. Select your query and F9 and compare to Ctrl+Enter. Both of those follow the same internal execution path and would be an apples to apples comparison just taking the statement detection logic out of the loop.

I just tried F9.

F9 and Ctrl+Enter show the same behaviour. They both take a long time to show the result in the Data Grid.

I have done CTRL+Enter for a long time too and never really had any problem with it if I remember to leave a space between my queries.